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11  AAbboouutt  tthhiiss  gguuiiddee  

The purpose of this guide is to help understanding the TRANUS application to the city of 

Swindon in the UK. TRANUS is an integrated land use and transport modelling system. The 

system is described in three documents available from www.tranus.com : 

 General Description of the TRANUS modelling system 

 Mathematical description of TRANUS (‘Math Manual’) 

 Graphical interface and database of TRANUS – TUS (‘TUS Manual’) 

 Models and report-generating programs of TRANUS (‘Programs Manual’) 

These documents will be referred to along this guide. With this guide it is hoped that those 

interested in applying the modelling system to cities and regions may use the model of 

Swindon as an example. The TRANUS software is available free from the same site. 

The preparation of this guide was made by Tomás de la Barra, Francesca Pagliara and Adriano 

Reale. We hope that others may send contributions to this first version of the guide. 

In this guide you will find an introduction with background information about the application 

of Swindon. Then the model design is described, explaining how the design is represented in 

the TRANUS database. Next the data that describes the base-year scenario is explained and 

also the way in which it is entered to the database and how to run the model. This is followed 

by the way in which the main results of the base-year scenario may be obtained and general 

information about how the model was calibrated. 

Future scenarios are described next, explaining how the scenario data is entered, the way in 

which the models are run and the results obtained. The way in which comparative tables are 

produced for both land use and transport results is described, accompanied with the 

comparative analysis of the results. Finally suggestions are given so that the reader may build 

his or her own scenarios to perform additional analysis. 

http://www.tranus.com/


Application guide to the model of Swindon  TRANUS 

 

 2 

22  AAbboouutt  tthhee  SSwwiinnddoonn  aapppplliiccaattiioonn  

The application of the TRANUS integrated land use and transport model to the city of 

Swindon in the UK was the outcome of a two-year research project, funded by the EPSRC in 

its Sustainable Cities Programme (Grant ref. GR/K 62170, Oct.1995 - Oct. 1997). The project 

involved collaboration between two universities, two firms of private consultants, and a local 

authority: 

The Open University Prof J P Steadman 

Centre for Configurational Studies Dr S Holtier 

The University of Manchester Dr F E Brown 

School of Architecture Mr J Turner 

Modelistica (Caracas, Venezuela) Dr T de la Barra 

Rickaby Thompson Associates (Milton Keynes) Dr P A Rickaby 

The former Borough of Thamesdown, now the Borough of Swindon 

Such partnership has a long tradition. Most members of the team originated from The Martin 

Centre at Cambridge University, UK. In the late 60’s and early 70’s Cambridge attracted a 

considerable number of scholars around a number of basic principles. Considerable research 

was carried out to understand the way in which cities and regions organize in space and evolve 

through time. The possibility of developing computer models of cities and regions was 

explored to considerable extent as a way to provide a rational support to the planning process, 

so that decisions and designs could be based on a solid, rational, basis. The interaction 

between the transport system, the location of activities and the real estate market was one of 

the main theoretical principles to be supported. 

In this project, an integrated land use, building stock, transport and energy model was built of 

the town of Swindon (Wilts) with its rural hinterland and adjacent villages. This model 

predicts the location of floorspace and land used by different activities, and simulates the 

associated traffic flows. It was used to explore four contrasted scenarios for the growth of 

Swindon up to the year 2016. 

The modeling software is TRANUS, developed by Dr de la Barra of Modelistica. The 

Swindon model was supported by a comprehensive database of information about population, 

employment, building stock, land uses, public transport services and the traffic network. The 

model makes detailed predictions for each of the 56 zones into which the study area was 

divided and for every link in the transport network. These results were displayed graphically 

in the ArcView GIS, but other GIS systems may be used to replicate them. 

The TRANUS model has a consistent micro-economic basis in random utility theory, and an 

input-output formulation in the land use sub-model. It is one of very few such models to 

incorporate energy calculations. In operation, the model starts from the existing level and 

spatial distribution of basic industry - that is industry that exports goods and services out of 
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the study area. Any increase in basic industrial employment will bring about a corresponding 

growth in (local) service industries, which the model estimates. Demands are created for new 

industrial, commercial and residential floorspace. The model simulates the real estate market, 

takes account of the supply of available land and its relative accessibility through the transport 

system, and predicts where the new activities will be located. The availability of very detailed 

data on buildings in Swindon made it possible to develop and test a unique representation of 

the floorspace market, disaggregated into different building types. All this sets the scene for 

the simulation of traffic flows. 

Depending on the relative locations of housing, industry and services, the model estimates the 

numbers of trips made for different purposes. It allocates these trips to modes of transport - 

private car, bus, train, cycle, walking - depending on relative costs and journey times. The 

resulting traffic is assigned to the network of roads and other transport links depending on 

distances through the network, and the capacities of the links. Any resulting congestion can 

affect journey times and cause trips to be re-routed. As the model is run for successive points 

in time, the interaction of land uses and transport in the first period determines a new pattern 

of land uses for the second period, and so on. Changes in the transport network, as for 

example bus lanes, park-and-ride services or restrictions on car traffic, can be introduced as 

new links in the network and/or changes in the attributes of links. Fuel consumption in 

transport is calculated for different types of vehicles depending on average speeds in each link 

in the network. Fuel consumption in buildings is estimated on the basis of floor areas and 

building types for different activities. 
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33  SSttrruuccttuurree  ooff  tthhee  mmooddeell  ooff  SSwwiinnddoonn  

The TRANUS modeling system is very general and flexible. Consequently, the first task in 

developing the model is model design, in which the modeler defines the main components that 

will represent the study area and the way in which such components are related to each other. 

The definition of sectors in the land use model is outlined, together with the main relationship 

among them. Details are given about the structure of the floorspace and land markets. The 

main components of the transport system are also described, including demand categories, 

modes, link types, public transport routes, and other elements. In both cases, the way in which 

the design is represented in the modeling software is described in some detail. 

In this case the modeling system is being applied to a relatively small English town. What is 

interesting in this application is that the study area is small with few zones, so that it runs very 

fast in our PCs of today, but the application is complex in that the structure of the model 

includes many sectors, floorspace and land, and the transport system also includes many 

features such as bus lanes, park-and-ride, integrated fares, and so on. 

The following sections provide a walk-through tour of the database, beginning with some 

general definitions, then the land use model and finally the transport model. 

3.1 General definitions 

Defining the project 

There are two ways of opening a project database: trigger the TRANUS user interface and 

then go File->Open, or use the Windows explorer to find the Swindon.tuz file and double-

click on it. Once the database has been opened, a window similar to the one shown in Figure 1 

should appear. The main components of this interface are described in full detail in the 

corresponding manual. At the top there are several menus, icons to perform tasks and a color 

palette. The big screen to the right is the network view and to the left is the scenario tree. 

Notice that when you open the application you get a specific view of the network with colors 

assigned to different entities, scale and other pre-defined elements. This is because the file 

Swindon.tuz is accompanied by another, much smaller, file called Swindon.ini. If the 

accompanying file is not present in the working folder, the network view defaults to some 

preset values. Most of the presentation settings are defined in the menu View->Options. 
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Figure 1: Main window of the TRANUS interface with the model of Swindon 

 

 

 

The menu Project->Options will show some general characteristics of the application, as may 

be seen in Figure 2. The scenario-tree appears to the left. The application is given a three-

characters code, in this case ‘SWN’. This code is important because it determines the names 

given to all files in the database. The description ‘Swindon Study’ is less relvant. 

Next there are three tabs: Coordinates, Transport and Land Use. The Coordinates tab shows a 

choice of coordinates system, either Windows or Cartesian. This refers to the way in which the 

coordinates of the nodes in the network are represented. They may be any units, generally 

meters, but Windows coordinates have the zero in the upper left corner, while Cartesian have 

it in the lower left corner. In this application Cartesian coordinates have been specified, and 

units are in tens of meters. This is because this is a rather old application, since nowadays 

most coordinate systems are UTM, that is, Cartesian in meters. Link length multiplier is a 

value used to calculate the length of links in the transport network on the basis of the 

coordinates of the corresponding nodes (assuming straight lines). As will be seen, link lengths 

are in kilometers, and because coordinates are in tens of meters, the conversion factor is set to 

0.01. 

Note that there is a button called Recalculate link lengths. When pressed, all link lengths in the 

network are recalculated. 

The other two tabs Transport and Land Use will be described later. 
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Figure 2: Menu Project->Options 

 

 

 

3.2 Definition of the land use model 

Study area and zoning 

The first element that must be decided in the model definition is the extent of the study area 

and its division into zones. The study area covered the town of Swindon (Wilts) with its rural 

hinterland and adjacent villages. 

For the purpose of dividing the study area into model zones, aggregations of census tracts 

were adopted, for a total of 56 internal zones and 9 external zones. As has been mentioned, 

this is a small number of zones compared to larger applications with ten times or more zones. 

The study area and the division into zones is presented in Figure 3, highlighting the urban area 

of Swindon. As may be seen, Swindon is surrounded by a number of satellite villages that 

gravitate around the city center. A few external zones were also introduced to represent 

external trips. In TRANUS, zones do not depend on scenarios. The number of zones must be 

the same for all scenarios and if you add or delete a zone in one scenario, they are 

automatically modified in all scenarios. 
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Figure 3: Study area and division into zones 
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In the TRANUS interface, zones are represented in the menu Project -> Zones. Figure 4 shows 

a section of the list of zones. Internal zones are assigned a black square, while external zones 

get a red square. Double-click on any zone in the list (or double click any zone in the network 

view) to see the data associated with each zone. 
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Figure 4: The menu Project -> Zones showing the list of zones 

 

 

Activities 

The urban economy of Swindon was divided into sectors of two types: employment and 

households. In turn, employment sectors were divided into exogenous and induced. 

Exogenous activities are assumed to depend on external elements, while induced activities are 

generated entirely within the study area by other activities. This division corresponds to an 

economic base assumption that is different to the more general input-output definition. In 

Tranus all sectors may have both exogenous as well as induced production. It is common to 

apply the economic base approach in urban applications for practical reasons. Households 

were divided into three income groups. In all, the following sectors were defined: 
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Activity sectors Type 

1 Industry and Agriculture Exogenous 

2 Government Exogenous 

3 Retail and warehousing Exogenous 

4 Office Induced by households 

5 Health Induced by households 

6 Education Induced by households 

8 Health Induced by households 

11 Households high income Induced by employment 

12 Households medium income Induced by employment 

13 Households low income Induced by employment 

 

The above list gives a Lowry-type structure. Exogenous-type activities induce the rest of the 

activities in the system. In turn, some induced activities generate other induced activities. The 

sequence is as follows: exogenous activities generate households; households in turn generate 

induced employment; induced employment generates more households. This sequence, shown 

in Figure 5 is repeated over and over until all activities have been generated. 

Figure 5: Lowry-type structure of activities in the model of Swindon 
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employment

Total
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Floorspace and land types 

In this model definition activities consume floorspace of several types, and in turn, each 

floorspace type consumes land, also of several types. In the model, the consumption of 
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floorspace and land is defined in a flexible way, to allow the model user to specify categories 

that are relevant to the study area. It is possible to define which activities consume which 

types of floorspace. Furthermore, a single activity type may choose to consume among several 

types of floorspace. In Tranus, this is called substitutive consumption, and estimated as logit 

choice probabilities, as described in the Math Manual. 

The following floorspace and land types were defined: 

 

Floorspace/Land type Consumed by 

21 Sheds floorspace Agriculture, Industry, Retail and Warehousing 

22 Framed floorspace Agriculture, Industry, Government, Retail, Warehousing and 
Office 

23 Detached floorspace Households High, Medium and Low 

24 Semi-detached floorspace Households High, Medium and Low 

25 Terraces and flats floorspace Households High, Medium and Low, and Agriculture, 
Industry, Government, Retail, Warehousing and Offices 

31 Industrial land Sheds and framed buildings 

32 Business Parks land Sheds and framed buildings 

33 Mixed land Framed buildings, terraces and flats, semi and detached 
houses 

34 Residential land Terraces and flats, semi and detached houses 

 

Figure 6 shows diagrammatically the relationships between activities and floorspace types, 

and between floorspace and land types. The diagram indicates where substitutions are defined, 

represented as logit choice models. It may be seen that all floorspace markets are related, even 

if not all possible combinations are defined. A certain distinction can be made between 

floorspace types typically consumed by employment sectors, and those related to households. 

However, both employment sectors and households compete for terraces and flats. It is 

important to allow for this, because in this way the model is able to represent the well know 

fact that many houses get converted into business. It is probably true that semi and detached 

houses are also subject to conversions, but this was not made explicit in the model definition 

for simplicity, and because this phenomenon is less noticeable. Similarly, land sub-markets are 

also related, because framed buildings may locate in mixed land. This is to account for the 

typical building with flats and shops in the ground floor. 

The various sub-markets are related in other ways, because activities themselves are 

functionally related. For instance, manufacturing employment does not consume semi and 

detached houses, but it does induce households, which, in turn, consume residential floorspace 

types. 
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Business parks is a relatively new type of land, and small compared to other uses. However, it 

was thought that it was important to include it in the model definition because of its growing 

acceptance, and may well grow in the future. 

Also note that there are some employment sectors that have been defined as not consuming 

any type of land. This is the case of health and education. In these cases it was assumed that 

these activities only consume special land, not incorporated to the real estate market. 

Figure 6: Choice sets between activities, floorspace and land 
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Setting up the definitions in the database 

The list of sectors is defined in the Land Use -> Sectors window, as shown in Figure 7. 

Double-click on any sector in the list (or Ctrl+E) to open the corresponding window with data: 

code name, description and elasticity, among others. Three types of sectors are possible: 

exogenous, induced transportable and induced non-transportable. 
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Figure 8 shows an example of an exogenous sector, defined as a sector in which all production 

is not consumed by other sectors explicitly. As was mentioned, sectors 1 Industry and 2 

Government are declared exogenous in this application. The program knows that these sectors 

are exogenous because it looks at the table of inputs (described later on) and finds that no 

other sector consumes these two. Consequently it will expect to find a zero in elasticity, since 

if no one consumes them, nothing will get transported. This is described as a sector that does 

not generate flows. 

Figure 9 shows an example of an induced sector (12 Households medium income) and this is 

represented by a >zero elasticity value. Finally Figure 10 shows an example of a non-

transportable sector (24 Semidetached floorspace). The program knows that this sector is 

induced, because other sectors consume it, but in this case finds that the elasticity value is 

zero. Consequently this is an induced non-transportable sector that generates no flows. 

Figure 7: The Land Use -> Sectors window 
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Figure 8: Definition of an exogenous sector in Land Use -> Sectors 

 

 

Figure 9: Definition of an induced sector in Land Use -> Sectors 
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Figure 10: Definition of a non-transportable sector in Land Use -> Sectors 

 

 

 

3.3 The land use-transport interface 

In the land use model exogenous and induced activities were defined. Because by definition 

no other activities consume exogenous activities, the model does not generate flows. Flows 

represent the functional relationships between consuming and producing activities. In the case 

of a pure input-output model such flows represent monetary transactions. In the case of an 

urban application, it is preferable to represent flows as the amounts of production (jobs or 

households) of one activity being generated by another one. For example, a job in an 

exogenous sector ‘consumes’ a certain amount of households of a certain type. The result is a 

functional relationship or flow. 

Floorspace and land sectors are by nature immobile or non-transportable. In the input-output 

jargon this means that they have to be consumed in the same zone where they are produced. 

Given the definition of sectors in the preceding section (see Figure 5), the following sectors 

are consumed by other sectors, and hence, generate flows: 

Retail and warehousing 

Office 

Health 

Education 

Households high income 
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Households medium income 

Households low income 

These flows are output from the land use model in the form of origin-destination matrices. 

They are used by the transportation model to generate actual trips of different types or 

transport categories. In principle, each flow in the land use model gives rise to a transport 

category. For instance, households are consumed by all types of employment sectors. Hence, 

each household category flows to jobs, generating one matrix each that may be transformed by 

the transport model to generate trips to work. 

The Tranus model allows for the formation of transport categories from socioeconomic flows 

in a variety of ways. Several flows may be combined into a single transport category in 

different proportions, or one flow category may be split into several transport categories. 

In the case of the Swindon application, a one-to-one relationship was established between 

flow-generating activity sectors and transport categories, as follows: 

 

Flow-generating activity sector To transport category 

Households low income Trips to work low income 

Households medium income Trips to work medium income 

Households high income Trips to work high income 

Retail and warehousing Trips to services 

Office Trips to services 

Health Trips to services 

Education Trips to education 

 

As may be seen, each type of household gives rise to an equivalent trips to work category, 

with the aim of having a degree of disaggregation of transport demand by economic groups. 

Retail, office and health were all aggregated into a single transport category called ‘trips to 

services’ adding up all income categories, while education is on its own, but also aggregated 

over income groups.  

Apart from the formation of transport categories from socioeconomic flows, there are other 

transformations that may be specified in the land use-transport interface. The main one to 

consider in this application is the transformation of time units. In the land use model, a month 

was considered as the basic time unit. This applies mostly to floorspace and land rents. In the 

case of the transport model a full day was taken as the main time dimension. The relationship 

between the two units is controlled by a time factor, explained further below. 

To represent this in the TRANUS interface, the Land Use -> Intersectors -> Categories 

windows is used, as shown in Figure 11. In the first example sector 3 Retail is generating 
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Trips to service, while the second example is sector 12 Hhds medium income generating trips 

to work midium income. 

Note that in order to define these relationships, both economic sectors and transport categories 

must have been defined before-hand. On this basis the software generates the matrices shown 

automatically. 

Figure 11: Generation of transport categories from economic sectors 

 

 

For each land-use transport relationship some additional parameters must be specified, as may 

be seen in the figures. These are: 
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Type: in the model there are two types of flows: 0 for normal type and 1 for commuter 

type (check the Math Manual for a detailed description, or press F1 to get a help 

window on this topic). In this case all flows are commuter type. 

Time factor: Sets the relationship between the time scale in the land use model and 

the transport model. In this application a month was set as the time unit in land use, 

and a day in transport. There are 30 days in a month, but people travel less on 

Saturdays and Sundays. Because they do a lot of shopping on Saturdays, a factor of 27 

was used for trips to services, and a factor of 22 for work trips. 

Volume factor: This is mostly used for flows of production giving rise to freight. 

Because there is no such sector in commuter flows, a factor of 1 is applied in all cases. 

Flow to production/consumption: In the land use model unidirectional flows result. 

In this case a total-day is assumed for transport, so that we want trips to go and come 

back, generating symmetrical matrices. To represent this, a factor of 1 is set for both 

trips to production and to consumption. 

3.4 Definition of the transport model  

The definition of the transport model involves two main elements: demand categories and 

supply categories. Supply, in turn, is divided into two: physical and operative. The physical 

supply includes the actual roads, railways, metro, LRT, stations, or whatever other elements 

may be present. Operative supply is composed of the various entities that provide a specific 

transport service. These may be bus companies, metro operators, park-and-ride operators, and 

the like. For modeling purposes pedestrians and automobiles are also considered as part of the 

operative supply. 

Demand categories 

Demand categories were described in the preceding section. Transport categories are defined 

in window Transport -> Categories as shown in Figure 12. Double-click on any category in 

the list to get the data associated with each one, as shown. These values will be described in 

further sections. 
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Figure 12: The Transport -> Categories menu 

 

 

 

Physical supply 

The physical supply of the transport system is represented in the form of a network, composed 

of links and nodes. The operative supply uses the infrastructure in order to provide 

transportation services. Zones are special kinds of nodes called centroids, where trips begin or 

end. 

Each link in the network has a number of characteristics associated to them, such as distance, 

capacity, the free-flow speed at which operators may travel, distance-related operating costs, 
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possible tolls and other charges, and many others. To simplify the process of coding all these 

characteristics for each link, the transport model classifies links by link type, so that a number 

of characteristics common to many links may be coded only once. 

For the Swindon model, the link types described in Table 1 were adopted. The list includes all 

the typical categories of roads and streets, in which each link type represents the area 

surrounding them (central, peripheral), the hierarchy (motorways, dual carriageways, etc.), 

and the maximum free-flow speed for cars, that serves as a basis for other types of vehicles. 

Special link types were defined for access links to centroids, and several others for future 

scenarios, such as railways, bus-only lanes, cycle ways, park-and-ride, and others. 

Table 1: Definition of link types 

Link type 
Id 

Short name Description Reference 
speed 

1 Access Access to zones without parking charges 25 kph 

2 Acc/wpark Access to zones with parking charges 25 kph 

3 CentNarr Central street narrow 30 kph 

4 CentWide Central street wide 38 kph 

5 PerNarr Peripheral street narrow 45 kph 

6 PerBroad Peripheral street broad 68 kph 

7 Mtway Motorway 90 kph 

8 DualCway Dual carriageway 80 kph 

9 CenNarrB Central street narrow buses only 30 kph 

10 CenWideB Central street wide buses only 35 kph 

11 AccessB Access to zones buses only (pedestrians) 5 kph 

20 Railway Railway line 30 kph 

21 Station Railway station (pedestrians) 5 kph 

22 P&R Park-and-ride 5 kph 

23 External For external zones 68 kph 

25 PerNarrRC Peripheral street reduced capacity (parallel to 
bus lanes) 

65 kph 

26 Cycle Cycle ways 12 kph 

27 BusLink Bus-only lane 35 kph 

28 CenNarrRC Central street narrow reduced capacity 
(parallel to bus lanes) 

30 kph 

29 CenBroadRC Central street broad reduced capacity 
(parallel to bus lanes) 

36 kph 

(*) In central zones parking charges were added, thus needing a separate link type 
(**) Some centroid connectors require that only cars may use them 
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The list of link types is introduced in menu Transport -> Link Types, as shown in Figure 13. 

Double-click any of the entities in the list to get the data associated with each link type. Such 

data is discussed later on, but one item relates to the definitions: the Administrator. Each link 

type must be associated with an administrator. 

Figure 13: The Transport-Link Types window 

 

 

 

Administrators are entities that are in charge of parts of the network. Administrators pay for 

maintenance costs, and may charge users for the use of the infrastructure in the form of tolls, 

airport taxes, parking, and so on. In the Swindon application not much use was made of the 

concept of administrators, as is common in urban applications. The list of administrators is 

shown in Figure 14 and may be checked in the Transport -> Administrators window in the 

model database. 
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Figure 14: The Transport -> Administrators window 

 

 

 

Operative supply 

The operative supply in the TRANUS model has three hierarchical levels: modes, operators 

and routes. Several routes may belong to an operator, and several operators may form a mode. 

Operators are sort of submodes. Transport demand categories may use one or more modes to 

travel, as defined by the model user. 

Although TRANUS allows for the typical private-public modal split, in the Swindon 

application a single-mode approach was used: passengers. This approach means that within a 

single choice set, all combinations are valid, subject to specific restrictions. In the realization 

of a trip, travelers may freely combine operators. For instance, a traveler may walk to a link 

where a bus service is available; then take a bus ride to a metro station; take a metro ride; and 

walk to the final destination. This scheme allows for auto-transit combinations. For example, 

the traveler may drive a car to a park-and-ride facility, then take the metro, maybe a bus, and 

walk to the destination. In theoretical terms, the single-mode approach means that the modal 

split model is skipped altogether. Instead, modal split and assignment are completely 

integrated. This flexible approach has been successfully applied in most applications in the 

last ten years, and is highly recommended. 

Some combinations may be prohibited. For instance, travelers may be prohibited to change 

directly from car to bus. They may only change from car to bus through an intermediate P&R 

operator. The latter means that car-public transport combinations are only allowed at specific 

locations where such facilities are available. If commodities were to be added to the system, 

such as truck movements, then a second mode would be required, with additional operators 

such as heavy and light trucks. 

In TRANUS operators may be of four types: normal, transit, transit with routes, and non-

motorized. The normal type is used for operators that may move freely around the network, 
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such as cars or trucks. Transit types may also move freely around the network, but charge 

fares and have a waiting time, such as a taxi. Transit-with-routes type operators are used to 

specify bus routes, LRT or metro. Non-motorized are used to represent walking and cycling. 

In the model of Swindon, the following operators were defined: 

 

Opertator Type 

Single-occupant car (SOV) Normal 

High-occupancy car (HOV) Normal 

Bus Transit with routes 

Minibus Transit with routes 

Walk Non-motorized 

Bicycle Non-motorized 

Rural bus, all types Transit with routes 

Passenger rail Transit with routes 

Park-and-ride Normal 

 

Note that there are two types of cars: SOV and HOV. These were defined as having an 

occupancy rate of one and more than two respectively. In this way travelers have the option of 

driving a car as a single occupant, or sharing the ride with others. This, in turn, has the 

advantage that average car occupancy is an output of the model, and is sensitive to policy. For 

instance, an increase in the price of fuel would shift the share of riders from SOV to HOV, 

increasing average car occupancy. This also means that car occupancy will vary among 

socioeconomic groups. Because lower income travelers are more sensitive to cost, the shared 

car is more attractive compared to higher-income groups. The scheme also allows for the 

introduction of HOV-lanes in future scenarios, as will be seen later. 

Two types of buses were defined: regular and express. This distinction was considered 

necessary because they provide clearly different services, with different speeds and tariffs. 

Also rural buses were added. 

The non-motorized operators included were pedestrians and bicycles. 

The rules permitting or restricting combinations among operators may be represented in a 

from-to operator matrix. The model also allows for the specification of integrated fares for 

specific combinations, but these were not introduced because they don’t exist in reality. 

Integrated tariffs were included in future scenarios as a policy. Table 2 and Figure 15 show 

which operators may be combined directly. 
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Table 2: Combinations between operators 

From/to SOV HOV RegBus ExpBus LRTBus Hartford Walk P&R Metro LRT 

SOV           

HOV           

RegBus           

ExpBus           

LRTBus           

Hartford           

Walk           

P&R           

Metro           

LRT           

Shaded: combinations not allowed 

Finally, for each combination of operators and link types, free-flow speeds may be defined. In 

a same link type, for instance, buses may go slower than cars. It is also possible to ban an 

operator from a link type. Specifying a speed of zero does this. For example, cars cannot travel 

along a metro line. The actual table of free-flow speeds is shown in the following chapter. 

Figure 15: Possible mode combinations in the transport system 

 

Walk 

Bycicle 

Railway 

Park and ride 

(P&R) 

Buses and 

minibuses 

High occupancy 

car (HOV) 

Single occupant 

car 
Single occupant 

car 

Walk 

Park and ride 

(P&R) 

High occupancy 

car (HOV) 

Railway 

Bycicle 

Buses and 

minibuses 

Integrated fares 

 



Application guide to the model of Swindon  TRANUS 

 

 24 

Modes are specified in the Transport -> Modes menu, as shown in Figure 16. Not much in this 

window because only one mode has been specified. 

Figure 16: The Transport -> Modes menu window 

 

 

Operators are specified in the Transport -> Operators menu, as shown in Figure 17. An icon is 

associated with each operator to denote type: a red car for ‘normal’, a blue bus for ‘transit’ 

(with or without routes) and a walking man for non-motorized. 

Double-click on any operator in the list to get the basic parameters associated with each 

operator, also shown in the figure. Each operator is given a short name and a description, and 

is assigned to a mode (the only ‘passengers’ mode in this application) and a type. In the 

example shown it is a minibus specified as ‘transit with routes’. 

Occupancy is set to 35. Because this is a transit with routes operator, this value means that the 

model may only assign passengers to routes of this type up to the capacity. As will be seen, 

each route has a frequency assigned to it. Multiplying maximum occupancy by frequency 

yields maximum capacity. In the case of cars, occupancy must be set to the average and 

demand is always equal to capacity. 

The Time Factor specifies the number of hours that a certain operator operates, in this 

example 16 hours. This is because this is a total-day application. For a peak-hour application 

this value would be 1. A minimum waiting time may be specified in decimal hours. In this 

example it has been set to 0.08 hours (about 5 minutes). Waiting time for transit with routes 

operators are calculated as half the interval, subject to this minimum value. Note that both 

Time Factor and Minimum Waiting Time are only meaningful in transit with routes operators. 
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Figure 17: The Transport -> Operators menu window 

 

 

The Transport -> Transfers menu specifies which operators may be combined with others and 

possible integrated fares, as shown in Figure 18. To ban a specific combination a value of INF 
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is entered, as for example from operator 2 HOV to operator 3 Bus. A value of zero means that 

there is no transfer cost for that combination, as in the case of from 4 Minibus to 5 Walk. This 

means that when you get off the bus and walk, you don’t pay anything. If you board a bus, 

either from walking or from another bus, a fare of 0.16 is paid. A rural bus charges 0.5. 

Driving a car to a P&R station costs 0.3, but then from the P&R to a bus does not cost 

anything. This means that the P&R service has an integrated fare with the buses. If a bus is 

boarded the fare is 0.16, and if you go into a P&R an additional fare of 0.14 is charged before 

you can pick up your car, to complete the 0.3 integrated fare. Note that in this example you 

cannot bike to a bus. You cannot walk half the way and then ride a bike or vice versa.  

Figure 18: The Transport -> Transfers menu window 

 

 

3.5 Land use data 

Once the application has been fully defined, as described in the preceding sections, data must 

be completed both for transport and land use. 

Production data 

Land use production data is specified for each sector and zone. This is done in the menu Land 

Use -> Economic Data , as shown in Figure 19. Depending on the nature of the sector, the data 

may be specified in different ways, so that the figure shows four different cases. 

The first window shows a typical exogenous sector, in this case sector 1 Industrial jobs. The 

data is input in the Exogenous Production column and represents the number of jobs in each 

zone. The model does not question this data and simply takes them as given values. 

Exogenous production gives rise to the rest of the activities and land. The column of attractors 

is not given any values because the model will not use them at this stage. This data may be 

specified by just typing it in, or by pasting it from another Windows application such as Excel. 

The latter is definitely the most practical way of doing it. 
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The second case represents an Induced Production sector: 12 Households Medium Income. 

Induced production is input in the Base Production column. This is no longer given data to the 

model, since the model must reproduce this information. Consequently the model will take 

this information and will try to approximate modelled values as much as possible. This will be 

explained in the next chapter. In this example the column of attractors is set to a value of 1 if 

there is production in a zone, or zero otherwise. The attractors are used by the model to 

simulate induced production. 

The third case represents a floorspace sector 25 Terrace in square meters. This is also an 

induced production sector so that production must go in the Base Production column. Just like 

the population example, the model will take this data as a target and will try to approximate 

the modelled values as much as possible for the base year. In this case the data has been 

copied to the Attractors column, in order to help achieve a good simulation. The values have 

been copied also to the Minimum and Maximum Production columns. The model will not use 

this information for the base year, but will pass it on the the next time period where they will 

be used as constraints. Note that a value of 2 has been specified for all Value Added. This is a 

very approximate way of putting a value to the buildings, in this case £ 2 per m
2
. 

The fourth case represents a land sector: 34 Residential land in square meters. This is similar 

to the floorspace example in that the values of production are copied in Base Production, Min 

and Max Production and Attractors. The difference is that the price of land is specified both in 

columns Price and Value Added. The model will build a value for the price starting from the 

Value Added values if any. Consequently it helps the model if the price values are also value 

added. Strictly speaking, they may be any positive non-zero values. 
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Figure 19: The Land Use -> Economic data menu window 
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Intersectorial demand functions 

As was described, exogenous production will consume induced production. In this example 

Industrial and Government jobs consume population, and population in turn consume retail, 

education and other induced jobs. Then all sectors consume floorspace of various types and 
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floorspace sectors consume land. Some of these relations are said to be inelastic, because a 

single constant value or coefficient represents the relation. This is typical of employment 

consuming population. In the case of floorspace and land consumption functions are elastic, 

because the amount of floorspace consumed by per population will depend on price. The same 

for floorspace consuming land. Furthermore, in this application substitutes were also 

specified, in which the need for floorspace for a specific activity may be satisfied by several 

types of floorspace, so that demand will be distributed among several options in a probabilistic 

way. 

These relationships are specified in the Land Use -> Intersector menu, combining the Inputs 

and Substitutes tabs, as shown in Figure 20. The example shows Sector 1 Industrial jobs. Each 

job consumes 0.1852113 households of high income, 0.2748599 households of medium 

income and 0.2290499 households of low income. Additonally each job in the industrial sector 

will consume floorspace of several types as substitutes. The Math Manual describes the form 

of the elastic demand functions, together with the logit model that is used to distribute demand 

over possible types of land. The following table summarizes this for the given example, that is 

industrial employment consuming floorspace: 

 

Floorspace type Minimum demand Maximum demand Penalty 

Sheds 55 110 0.45 

Framed 50 110 0.45 

Detch    

SemiD    

Terrace 45 110 0.5 

 

When an industrial job consumes Sheds it will consume at least 55 m
2
 per job and up to 110 

m
2
. In this example industrial jobs may also consume Framed and Terraces. The penalty factor 

multiplies expenditure, so that smaller values mean a positive preference. In this case 

industrial jobs prefer sheds and framed buildings over terraces. Note that they cannot consume 

detached and semidetached houses. Similar specifications are made for every sector. 

The penalty factors may be any positive value and they do not have to add up to one. It may 

well be that not all possible floorspace types are present in every zone. In the example above it 

could be that in a specific zone, such as an industrial estate, there are no terraces. In this case 

the model will distribute consumption among the remaining types sheds and framed. 
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Figure 20: The Land Use -> Intersectors window menu to specify inputs 
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3.6 Transport data 

Transport network: nodes, links and routes 

As was mentioned, the transport network is made of nodes and directional links. Nodes are 

specified in the Transport -> Nodes menu, as shown in Figure 21. Each node is given an 

identifying number, optional names and description and XY coordinates. As was mentioned, 

in this application non-geographical coordinates were used and values are in tens of meters. 

Nowadays most applications will be in UTM geographical coordinates in meters. 

Like zones, nodes are not scenario-dependent. If a node is moved or deleted, it applies to all 

scenarios. There are, however, nodes that are used in a scenario and nodes that are not. A node 

is defined as not-used if no link uses it. This is shown in the list with a green square if used, 

gray square if not used. 

Data may be entered to the database by typing them in. However, in many applications the list 

of nodes may be quite large, with several thousand nodes. Also the data may be obtained from 

a GIS database in an automatic fashion. The interface provides a special facility to import a 

list of nodes with corresponding coordinates in the menu Project -> Import Network. 

Figure 21: The Transport -> Nodes menu window 

 

 

Nodes are connected by links. The list of links is displayed in menu Transport -> Links, as 

shown in Figure 22. A double-click on any link in the list displays the characteristics of the 
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link, as shown in the bottom half of the figure. In this case it is a link of type ‘Peripheral 

Broad’. Length is 0.6 Km and the capacity is 2500 standard vehicles per hour. 

Figure 22: The Transport -> Links menu window 
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The network view shown in Figure 23 displays all links with a colour code. To get this view 

make sure the Link Types tab is selected on the right panel and Color is selected in the left 

panel. Colours may be changed at will. The thickness of each link is proportional to the 

capacity, and the scale may be changed in menu View -> Options. 

Figure 23: Network view showing link types and capacities 

 

 

Select the Transport -> Link Types menu and choose the Operator Data tab to see the 

characteristics assigned to each operator in each link type, as shown in Figure 24. In this 

example link type 6 Peripheral Broad was selected. The complete list of operators is presented 

and the first column shows the maximum operating speed of each one, also called free-flow 

speed. For instance SOV cars may go up to 68 Km/hour, HOV cars at 64, buses at 50 and so 

on. Operators with no speed mean that they cannot travel along links of this type, as is the case 

of Rail and P&R in the example. The column Charges is where tolls or any other is specified, 

not in this example. Penalizing Factor multiplies the value of time of all users travelling along 

links of this type. Distance Cost is the operating cost of vehicles per unit of distance. 

Equivalent Vehicles is a parameter that multiplies the number of vehicles in the link to get 

standard or equivalent vehicles. It is also called PCU (passenger car units) in the literature. For 

example, a bus is equivalent to 2.5 equivalent units, while the SOV car has been taken as the 

unit with a factor of 1. Overlapping Factor multiplies the value of time at path search (see the 

Math Manual for a full description of this process). A high value means that the program will 

try that this link is not repeated along paths. Marginal Maintenance Cost is not used in this 

application. 
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Figure 24: The Transport -> Link Type menu showing Operator Data 

 

 

 

Finally public transport routes are defined in menu Transport -> Routes shown in Figure 25. In 

all there are 43 routes, but no all of them are used in the base year scenario. Note that some 

routes are presented with a green square to denote that they are used in this scenario, no square 

if they are not used, and a red square if the route is used but the program thinks there might be 

something wrong or at least suspicious about this route that is worth checking. 

If any route in the list is selected, another window showing data is displayed. In the figure 

route 306 is presented. It belongs to operator 3 Bus and has a frequency of 6 buses per hour. 

The ‘Used’ box is checked as well as the ‘Follows Schedule’ box. The latter means that this 

route has a timetable that users know, so that they will wait a fixed minimum amount of time 

as specified in Transport -> Operators. 

Select the Routes tab to get a network view of public transport routes, as shown in Figure 26. 

In this example all bus routes were given a blue colour. Walk was given a light blue colour 

and bike was given yellow. Cars were not assigned any colour. Because all buses were given 

the same colour, the network view displays the sum of all routes. The bandwidth is 

proportional to the capacity of routes. Assign a single colour to a specific route to see its 

itinerary. It is possible to double-click on any of the routes in the left panel to display the 

corresponding Transport -> Routes window. 
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Figure 25: The Transport -> Routes menu window 
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Figure 26: Network view showing public transport routes and capacities 
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44  RRuunnnniinngg  aanndd  aaddjjuussttiinngg  tthhee  bbaassee  sscceennaarriioo  

This chapter describes the way in which the base scenario is run and reports about the results 

that are obtained. Also the way in which the model is adjusted to calibrate the model against 

data is discussed. 

The base scenario was defined as 1991 and the three-letter code was set to 91A. 

4.1 Running the base scenario 

The TRANUS interface provides a special menu to run the model programs. See the TUS 

Manual for more details about running scenarios. The procedure is quite simple, as will be 

seen below. When one or more programs are run, the interface automatically performs the 

following functions: 

 creates a folder to hold all scenario-related data (in this case the folder will be 91A) 

that hangs from the application folder 

 generates a set of data files, most in the scenario folder but also s few in the application 

folder 

 runs the corresponding programs that in turn generate a number of files in the scenario 

folder to hold all results 

The Project -> Run menu 

Before running the programs, check some options in menu Project -> Options, as shown in 

Figure 28. The Land use tab shows that the land use model will be run for up to 200 iterations 

(unless it converges before), and the convergence target is set to 0.0001. The transport model 

will run for up to 18 iterations with a convergence criterion of 0.001. In both cases a 

smoothing factor of 1 is specified, which means that the values of each iteration are averaged 

with those of the previous iteration in equal proportions. 
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Figure 27: Menu Project -> for land use and transport 
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To run the models for the base scenario simply select the Project -> Run menu. Make sure the 

91A scenario is selected in the left panel. The menu offers two basic choices: all programs, or 

selected programs. In this case we are interested in running all programs. After this choice 

press the Add to Batch button, and a list of the programs that will be run appears in the right 

panel. The list of programs is as follows: 

 Path search: runs program PASOS, the multimodal path search procedure 

 Initial assignment: runs a single iteration of program TRANS, the transport assignment 

model, and then runs COST, the cost adjustment program 

 Location: runs program LCAL, the Land Use model used for the base year scenario, 

and then runs FLUJ, the flows adjustment program 

 Assignment: runs all iterations of program TRANS, and then runs COST again 

As may be seen, the interface knows that you want to run the base scenario, because it is the 

one at the top of the scenario tree, and selects the programs accordingly. Next press the Run 

button. A black window is presented with messages reporting the progress of the programs. 

Some error or warning messages will also appear. Once all programs have run, you may save 

all the information in the screen by selecting it, Ctrl+C to copy and Ctrl+V to paste it in any 

program such as Word or NotePad. Running all programs should only take a few minutes. 

Figure 28: The Project -> Run menu window 

 

 

Program PASOS will display the following messages: 
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The program is reporting that it found 472 links in the base scenario network, that combined 

with transit routes and other operators makes a multimodal network of 2737 links. ADY is the 

procedure to build the dual network, and the message is reporting that it is using less than 1% 

of the capacity of the program (a= 0%). It then builds the paths for all origins and uses 3% of 

the model capacity. The program took 0.1 mins to run on a 2.2 GHz Dual Core. 

The Initial Assignment screen does not contain much information, just a progress report. 

The Location screen is much more interesting, with a table for each iteration. Convergence of 

the model is evaluated on a sector-by-sector basis. Because 200 iterations were made, only the 

last table is shown here for iteration 200: 

 

 

 

Convergence indicators 
Sector           ConvPric   Zon   ConvProd   Zon   ExogProd   InducProd 
1 Indus          0.000013   18     0.000000     0        43615.                 0. 
2 Govm         0.000007   37     0.000000     0         4062.                  0. 
3 Retail         0.000001   52     0.000000    15              0.           25642. 
4 Office         0.000001   32     0.000000    23              0.           23086. 
5 Health        0.000001   75     0.000000    19              0.             3118. 
6 Eductn       0.000001   71     0.000000    30              0.             7004. 
11 HhHigh    0.000001   59     0.000000    38              0.           19730. 
12 HhMed     0.000001   75     0.000000    71              0.          29280. 
13 HhLow     0.000001   53     0.000000    74              0.          24400. 
21 Sheds    - 0.000121   23    -0.000135    23             0.       1403691. 
22 Framed   -0.000134   23     0.000516    18             0.       1205309. 
23 Detch       0.000009   38     0.000003    54             0.       1996788. 
24 SemiD     -0.000002   37    -0.000004    38            0.       2186582. 
25 Terrace    0.000010    6     -0.000007    38             0.       4173464. 
31 IndLnd     0.000273   12     -0.000139    23             0.              583. 
32 BPark      0.000263   12      0.000024    35             0.                95. 
33 Mixed    - 0.000105   38      0.000396    18             0.              190. 
34 ResL      -0.000091   38     -0.000009    37             0.            3556. 

P A S O S :  PATH SEARCH BY MODE 
READING PARAMETERS AND DATA 
VERIFYING REPEATED LINKS... 
Total number of links in the network: 
         472        2737 
PATH SEARCH BY MODE 
  ADY   Mod    1 (100%)  a=( 0%)      )  
  PAS   Mod   1  Orig      89(100%) h=( 3%)                       
Run time:    0.101 mins 
NORMAL END OF P A S O S 
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The model evaluates two convergence indicators: convergence of prices (ConvPric) and 

convergence of production. In the example, sector 1 Industry shows a convergence of 

0.000013 (0.0013%) in prices. The model takes the worst case, that is, the zone in which the 

price changed the most with respect to the previous iteration, and this took place in zone 18. 

Production did not vary, because Industry is a totally exogenous sector, so that production 

does not vary. Two additional columns show exogenous production and induced production 

accumulated up to this iteration. Because (again) sector 1 is totally exogenous, only exogenous 

production must be shown, in this case 43615 jobs. 

At the end there is a message saying “Last iteration without convergence”. This is because 

iteration 200 was reached before the convergence criterion was fully met. These parameters 

are specified in menu Project -> Optons -> Land Use, as shown in Figure 29. However, 

achieved convergence is quite good, so that it was not thought necessary to increase the 

number of iterations. 

 

Figure 29: The Project -> Options -> Land Use menu window 

 

 

Next the Transformation of Flows procedure was performed by running program FLUJ 

automatically, displaying a progress report only. 

The (Final) Assignment screen also reports results for every iteration, as follows: 
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The transport model evaluates convergence with two indicators: convergence in flows and 

convergence in speeds, again showing the worst case, that is, the link that varied the most. In 

the first iteration it is not possible to evaluate the variation in flows, because there is no 

previous iteration flows to compare. Speed can be compared, because at the end of iteration 1 

there might be congestion slowing down the vehicles. In this example, the worst case of 

iteration 1 happened in 2102-2101 that varied 41%. Note that the convergence criterion is 

always shown as 0.001. The program reached iteration 18 without fully converging, since 

flows show an indicator of 0.161% as worst case in link 15-1501, that is a little bit greater than 

the convergence criterion. Worst case in speeds happened in link 1404-801 with a variation of 

0.0046% with respect to the previous iteration, well bellow the convergence criterion. These 

parameters are specified in the Project -> Options -> Transport menu, as shown in Figure 30. 

Iter Categ Origin ConvObj    ConvFlows         Worst     ConvSpeed          Worst 
   1    6        65     0.0010000 F ********          (    0    0)    V  0.41855 (  2102  2101) 
   2    6        65     0.0010000 F  0.56633   ( 6301  402)    V  0.46569 (   701   601) 
   3    6        65     0.0010000 F  0.34746   (  402 6301)    V  0.47645 (   701   601) 
   4    6        65     0.0010000 F  0.26442    (  201  101)    V  0.46644 (   701   601) 
   5    6        65     0.0010000 F  0.22323    (  201  101)    V  0.41205 (   701   601) 
   6    6        65     0.0010000 F  0.20525   ( 1201 1202)   V  0.25622 (   701   601) 
   7    6        65     0.0010000 F  0.10881     (   15 1501)   V  0.17188 (   601  1201) 
   8    6        65     0.0010000 F  0.06650     (   15 1501)   V  0.04902 (  1902  1202) 
   9    6        65     0.0010000 F  0.02592    (  601 1201)   V  0.01834 (   701   601) 
  10    6       65     0.0010000 F  0.01704   ( 3701 1403)   V  0.01333 (   601  1201) 
  11    6       65     0.0010000 F  0.02813     (   15 1501)   V  0.00821 (   701   601) 
  12    6       65     0.0010000 F  0.01053       (    7  701)   V  0.00956 (   701   601) 
  13    6       65     0.0010000 F  0.00862       (    7  701)   V  0.00523 (   701   601) 
  14    6       65     0.0010000 F  0.01620     (   15 1501)   V  0.00274 (  1404   801) 
  15    6       65     0.0010000 F  0.00335     (   15 1501)   V  0.00122 (  1404   801) 
  16    6       65     0.0010000 F  0.00832     (   15 1501)   V  0.00136 (  1501  1404) 
  17    6       65     0.0010000 F  0.00357     (   12 1201)   V  0.00062 (   702   301) 
  18    6       65     0.0010000 F  0.00161     (   15 1501)   V  0.00046 (  1404   801) 
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Figure 30: The Project -> Options -> Transport menu window 

 

 

This ends the sequence of programs. Note that the land use model ran with transport costs and 

disutilities that were calculated with the ‘initial run’ of the transport model, based on free-flow 

speeds. Once the land-use model ran, the transport assignment model was applied, this time 

with flows from the land use model, giving rise to congested transport costs and disutilities. 

Because these values affect the location of activities and land use, it is necessary to re-run 

location and assignment. This is done by selecting the Project -> Run menu again, specifying 

additional runs, as shown in Figure 31. This time the option Selected Programs is chosen to 

check on Location and Assignment, since there is no need to run Path Search again nor Initial 

Assignment. Note that running Initial Assignment again is equivalent to starting from scratch. 

In theory land use and transport should be run many times to achieve equilibrium. It is not 

straightforward to assess when such equilibrium has been reached without considerable work. 

In practice it is safe to say that a couple of spins is enough. For the purpose of this guide we 

shall repeat the process only once. 

Once the second run has been completed, the next step is to find out what the results look like. 

Did the model behave properly? Was data properly reproduced? These are the issues 

addressed in the following sections. 
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Figure 31: The Project -> Run menu to perform additional runs 

 

 

 

4.2 Land use results 

There are several programs that read the results of the models and present them in readable 

table-like fashion. In the case of land-use results, the main program to obtain results is called 

IMPLOC. Read the Programs Manual to get instructions to run this program. The land use 

model, however, automatically generates a file called locaton_indicators_91A.csv. This is a 

comma-separated-values text file that is easy to read with any spreadsheet program such as 

Excel, as shown in Figure 32. 

Note that the file present numbers with a dot as decimal delimiter. Make sure that Excel 

assumes this also (if not use Windows’ Control Panel to set a dot as delimiter and a comma as 

separator). 

The file contains a heading and then a table with values for each sector and zone, in this case 

sector 1 Industrial employment. The main columns of data are: 

Scen the scenario code (in this case 91A) 

Sector the economic sector (in this case 1 Indus) 

Zone the zone each row refers to 

TotProd Total production, the sum of possible exogenous and induced production 

TotDem Total demand, the sum of possible exogenous and induced demand 

ProdCost Production Cost 

Price Price 

MinRes Minimum restriction 

MaxRes Maximum restriction 



Application guide to the model of Swindon  TRANUS 

 

 46 

Adjust Price adjusting factor 

Note that scientific notation is used throughout, but it is easy to change to a more familiar 

format in the spreadsheet. In this case Industrial employment is totally exogenous, that is, all 

production is exogenous and no other sector demands it. Consequently all production is in the 

column TotProd and TotDem is always zero. Note that with this format it is easy to produce 

Dynamic Tables in Excel and other spreadsheets. 

Production Cost and Price must be equal, because this is an unconstrained sector. These values 

have been calculated by the model as it works through the input-output procedure. It is the 

sum of whatever this sector has consumed, in this case population, floorspace and land. 

MinRes and MaxRes are always zero because no restrictions have been imposed. The price 

adjustment factor (see the Math Manual) adds or subtracts a a certain amount to the price in 

order to approach simulated induced production to data values. The values are presented as a 

percentage of the price. In the case of an exogenous sector like this one, there is nothing to 

adjust. 

Figure 32: Land use results displayed in a spreadsheet 

 

 

Figure 33 shows the results for Sector 3 Retail employment, an induced sector further down 

the table, with the scientific notation changed to a number format with no decimal places, and 

the first row frozen to show the name of the columns. Because the production in this sector is 

consumed by other sectors, values are present in both TotProd and TotDem. In the example, 

78 jobs were produced in zone 1. Demand for retail jobs in that zone is bigger, 174. This is a 

transportable sector, so that the 78 jobs produced in zone 1 may have been consumed partly in 

zone 1 and partly in many other zones. Because it is an unconstrained sector ProdCost and 

Price are the same. In zone 1 the cost of producing one job is £ 1,269. MinRes is zero and 

MaxRes is a very large number, which means that there are no restrictions. The adjustment 
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factor is -66.54 in zone one, which means that the price was reduced by 66% in order to 

achieve the production of 78 jobs. 

Figure 33: Land Use results, showing an induced sector 

 

 

Finally Figure 34 shows a non-transportable sector 23 Detached Houses. The main difference 

is that production and demand must be the same, since houses must be produced and 

consumed in the same place. Again here ProdCost and Price are the same, even if it is a 

constrained sector. This is because it is the base year, since they may become quite different in 

future scenarios. Columns MinRes and MaxRes show the minimum and maximum constraints 

that were entered in Land Use -> Economic Data. These should be as close as possible as 

production values. In the case of zone 1 the difference was minimized with and adjustment 

factor of 38.11% of the price. 
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Figure 34: Land-use results in Excel, showing a non-transportable sector 

 

 

4.3 Transport results 

There are three ways of viewing transport results. The first one is similar to that described in 

the preceding section, that is, by simply opening files that are generated automatically. The 

second form is to run programs that generate text-based reports. The third way is to use the 

same interface TUS to display transport results graphically in the form of thematic maps. 

Two files are generated automatically: 

transport_indicators_91A.csv, and  

route_profile_91A.csv 

Text reports may be obtained with three programs (see Programs Manual): 

IMPTRA presents a menu with several options to produce link-based results or 

indicators with a variety of formats. 

MATS presents a menu with options to produce matrices of several types, such as trip 

matrices, costs, disutilities, and many others. This program is also used to present land 

use matrices. 

MATESP also presents a menu with options to produce ‘special matrices’, such as O-

D matrices that use a link or an operator, matrices of transfers, and others. 

The resulting file transport_indicators_91A.csv may be opened in Excel just like in the 

previous example, since it is a text file with values separated by commas. The first row 

contains the headings of each data column with global indicators of the transport system for 

the whole study area. As in the previous case, Dynamic Tables are easily built from the basic 

data table. The data table contains the following columns: 
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Scenario 

Table 

Object 

Subobject 

Value 

Figure 35 shows the first part of the data table, corresponding to a table called Trips by 

cat/model. The object in this case corresponds to transport categories such as 1 HWHigh 

(home-work trips by high-income population). The subobject in this case is the only mode in 

the system: Passengers. The first row indicates that this category makes 84,313 daily trips. 

These represent door-to-door trips, so that if there are transfers with several boardings along 

the way, they are still counted as one trip. 

Figure 35: Transport indicators data table 

 

 

From this table, another table with a nicer format may be produced by making simple 

references or using the Dynamic Table utility in Excel. 

Further down the file general statistics by transport categories are found, as shown in Figure 

36. The indicators include distance travelled, monetary cost, and travel time. In this example 

category 1 Home to work high income travel a total of 673,921 Km (if we divide this by the 

number of trips an average trip length of 8.04 Km results). Note that there are external trips in 

a separate category in order to avoid distortions to the indicators. 
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Figure 36: Statistics by transport category 

 

 

Further down the data table results by operator are presented, as in Figure 37. The first is 

boardings by operator, such that a trip that involved, say, walking and then boarding a bus will 

appear both as a bus trip and a walk trip. If we add all boardings we get a total of 841,134 that 

is larger than the total number of trips by category, 652,387. 

Units-Dist represents, in this case, passenger-Km travelled. By far the greatest figures 

correspond to the two types of cars, but it is interesting to note that there are as many trips and 

passenger-Km in bike compared to buses. Note that in the base scenario there are no trips by 

rail and no park-and-ride. These will be introduced in future scenarios. 

Energy is, in this application, the amount of fuel consumed in litres. This indicator may be 

used to calculate emissions. It is clear that cars consume an enormous amount of fuel 

compared to buses. An interesting exercise is to divide the litres by passengers-Km to get an 

efficiency indicator that may be viewed also as a pollution indicator. 

Further down, Costs are the operating cost of vehicles in daily units, including the cost of fuel, 

in Sterling pounds. Income is what the operator receives, and revenue is just income-minus-

cost. This is only relevant for the buses. Cars shouldn’t have any revenues, but because users 

do not perceive all of the cost (as specified in Transport -> Operators -> Cost) they show up in 

the table as loosing money. 
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VehKm is vehicle-Km travelled. In the case of SOV cars, vehicles travel the same as 

passengers, because the occupancy rate is set to 1.0. In the case of HOV cars passenger-Km 

are more than twice the vehicle-Km. Dividing these two indicators yields another efficiency 

indicator. VehHrs is vehicle-hours. Divide VehKm/VehHrs to get average speed. 

Figure 37: Statistics by operator 

 

 

Further down the file there are values with statistics by administrator, as shown in Figure 38. 

Each administrator may have income from tolls or other charges, and have maintenance costs. 

In this application the base year only has one administrator: ‘County’, and no maintenance 

costs were specified. County perceives an income from parking charges in some downtown 

zones (see Transport -> Link Types -> Operator Data for Link Type 2 Access with parking). 
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Figure 38: Statistics by administrator 

 

 

At the end of the file there is a set of tables combining categories and operators. The first of 

these tables, shown in Figure 39 presents values in terms of boardings. This is useful to see 

which categories use certain operators the most. For instance, high-income trips home-work 

make 45,931 trips by SOV car (46%), while low-income home-work trips by SOV are 26,843 

(18%). By contrast, high-income make 4.7% of their trips by bike, while low-income make 

9.1%. This is because high-income travellers have a high value of time, so that they favour 

faster modes even if they are more expensive. 

Figure 39: Boardings by category and operator 
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To get thematic maps of transport results, use the File ->Open menu in the interface to open 

the results. Look for the 91A folder and in there open a file called SWN91A.T3S. Once 

opened, you may set colours and scales to get the appropriate network view. An example is 

shown below in Figure 40 in terms of demand values, in this case, passengers by operator. 

SOV cars are red, HOV cars pink, buses green and bikes and pedestrians light blue. The 

bandwidth is proportional to the number of passengers in each link. 

Figure 40: Network view showing demand values (passengers) by operator 

 

 

 

4.4 Adjusting floorspace and land demand functions 

The Swindon model already went through the calibration process, so that there is no need to 

adjust anything. However, it is a good exercise to go through some of the main functions that 

must be estimated and adjusted at the calibration stage of model development. In this section 

we look at the elastic demand functions that are present in considerable number in the land use 

model. 

When reviewing the model structure, two main types of demand functions were described: 

elastic and inelastic. The model treats both the same way, defining inelastic functions as 
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elastic functions with elasticity = 0. In the Swindon application, jobs consume residents, and 

in turn, residents consume jobs. These relationships are represented as inelastic functions, that 

is, one unit of job of a specific sector will consume a fixed, constant, amount of households of 

a specific type. By contrast, when activities consume floorspace they do so with an elastic 

function, that is, with a minimum and a maximum amount and an elasticity parameter with 

respect to expenditure (see the Math Manual for an explanation on this). If the price of a house 

becomes too expensive, people will react either by changing location or consuming smaller 

amounts. In turn, in the model of Swindon floorspace consumes land of various types, also 

with elastic functions. This means that as land becomes expensive, plots of land will get 

smaller. 

In this section we will use two reports generated by program IMPLOC. Run this program from 

a command window in the application folder, to get a menu like this one: 

 

 

 

Option 5 produces a set of tables with consumption coefficients by sector, while Option 6 

produces a set of tables with total consumption by sector and zone. You may choose any name 

for the files. The resulting files may be opened with Excel (tab delimited). 

Figure 41 shows two sections of the unit consumption report. The upper view corresponds to 

sheds. There are only two sectors that consume this type of floorspace, according to the model 

definition: industrial employment and retail employment. The table shows the amount of 

floorspace that each unit of activity consumes. In zone 1, one unit of industrial job consumes 

79.467 m2 of shed-type floorspace, while a job in the retail sector consumes 115.62 m2. Note 

that the minimum and maximum consumption, shown in the header of the table, are 55 and 

110 m2 for industrial jobs and 40 and 210 m2 for retail. The amounts consumed in zone 1 are, 

therefore, somewhere in between, depending on elasticity and prices. The price of a unit of 

sheds floorspace is the same for all activities in zone 1. 

──────────────────────────────────────────── 

 I M P L O C : DISPLAY LOC RESULTS 

 ──────────────────────────────────────────── 

 

 ┌───────────────────────────────────────────────────┐ 

 │ Display options:                                  │ 

 │                                                   │ 

 │   [1] All information by sector and zone          │ 

 │   [2] Total production by sector and zone         │ 

 │   [3] Total production by year/policy             │ 

 │   [4] Internal information by sector and zone     │ 

 │   [5] Consumption coefficients by sector          │ 

 │   [6] Total consumption by sector and zone        │ 

 └───────────────────────────────────────────────────┘ 

                              Option ---> 1 
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The bottom half of the figure shows a section of the table further down, in which activities are 

consuming semidetached floorspace. In this case retail, office, and the three types of 

households consume this type of floorspace. 

Figure 41: Unit consumption of floorspace with elastic demand functions 
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Figure 42 shows the tables that result with Option 6, that is, total consumption. Remember that 

these are substituive consumptions. In each zone activities may choose between alternative 

floorspace types. Not all types will be available in every zone. In the example, retail would 

consume 115.62 m2 of sheds per job, if there is any stock available. However, there are no 

sheds in zone 1, as shown in the table below. The preceding table also showed that a retail job 

would consume 42.06 m2 of semidetached floorspace. In this case zone 1 does have 

semidetached floorspace, so that in all retail jobs consume 829.93 m2. There are also other 

types of floorspace in zone 1 that retail may consume, in addition to semidetached. Look in 

the table for all types of floorspace that retail jobs consume. 

Figure 42: Total consumption with elastic demand functions 
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4.5 Adjusting transport assignment 

There are many things to adjust in the transport model. A few of these are described in this 

section. One of the first elements to consider is the number of trips per category and modal 

shares. 

The number of trips per category is adjusted in the menu Transport -> Category. The resulting 

table has already been shown in Figure 35, in terms of the total number of trips by category. In 

this application there is only one mode: passengers, but many submodes or operators, as was 

shown in Figure 37. The number of trips depends on the trip generation parameters as shown 

in Figure 43 below. The figure shows the menu when opened, and then what you get if you 

select any of the categories. In the example category 2 Medium income home-work trips is 

shown. Parameters are minimum trip generation rate = 1, maximum = 2, elasticity is 0.003. 

During the calibration stage, these values must be adjusted until the correct number of trips is 

obtained. Elasticity also has an effect on the mean trip length. 

Submodal shares are affected by a number of variables, such as travel times, fares, waiting 

times, values of time, and so on. Each category-operator combination must be adjusted until 

the correct share is obtained. Once all variables have been entered, there is a set of penalties to 

represent non-modelled components. The main set is the operators-categories penalty factors, 

shown in Figure 44, corresponding to the Transport -> Operators menu. The HOV car was 

selected, and shows that there is a penalty of 1.7. This compares with the SOV car with a 

penalty of 1. The HOV car is much cheaper than the SOV car, because the cost is being shared 

by two or more passengers, and it is just a little bit slower (see Link Types). Consequently, if 

both SOV and HOV have a penalty of 1, all passengers will choose HOV. In practice, 

however, most people find that HOV cars are not very convenient because some sort of 

previous arrangement must be made with the other car-sharers, probably including the return 

trips as well. Also car-sharers must coincide in destination and times of day. Statistics show 

that only a small proportion of travellers choose HOV, and the proper share was obtained with 

the 1.7 penalty factor. Note that you may specify specific combinations between operators and 

categories selecting the ‘categories’ tab. This possibility was not used in this application. 
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Figure 43: Trip generation parameters in menu Transport -> Categories 
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Figure 44: The operators-categories penalties 
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55  TThhee  TTrreenndd  SScceennaarriioo  

This chapter describes the way in which future scenarios are defined, calculated and reported, 

taking the Trend Scenario as a first example. This scenario goes into the future assuming 

growth, but maintaining land use and transport policies as they are today, unchanged. 

In TRANUS scenarios are defined as a scenario tree, as shown in Figure 45. All scenarios data 

are stored in the same database, and follow certain ‘intelligence’. In this example, the base 

scenario 91A is followed by an intermediate scenario 96A. This setup was chosen because the 

study team had data for both periods, so that the dynamics of the model could be tested. The 

only scenario that ‘hangs’ from 91A is 96A. Following that there are many branches A, B, C, 

D and T. In this chapter we concentrate on the latter, called the Trend Scenario, as described. 

The Trend Scenario branches down as 01T, 06T, 11T and 16T, with a steady five-year 

interval. Scenarios are defined in the Project -> Options menu. See the TUS Manual for a 

detailed description of how scenarios work. 

Figure 45: The scenario tree in the TRANUS database 
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It is now possible to ‘navigate’ up and down the scenario tree. If there are any changes in the 

network, they should become visible in the network view. However, the Trend Scenario does 

not include any changes in the network. 

5.1 Defining growth and land-use constraints 

Before running future scenarios, they must be defined in the database. As mentioned, the 

Trend Scenario does not include changes in the transport system, but it does contain some 

expected changes in land use: growth and land-use constraints. 

In this application there are two exogenous sectors: industry and government. In the Trend 

Scenario growth has been defined for these sectors in terms of a global amount of jobs that 

will be added. The model will allocate this total amount to all zones based on a simple 

probabilistic model that you define, as will be shown. It is also possible to assign specific 

amounts in specific zones, but this has not been done in the Trend Scenario. 

The functions that determine the allocation of the global amount to each zone are defined in 

Land Use -> Intersectors -> Exog Attractors, as shown in Figure 46. Three variables are 

defined for the growth of Industrial employment: Industrial employment itself, Industrial Land 

and Business Parks Land, with weights of 0.8, 1 and 0.8. In all cases the values of production 

are being used, such that it is the production of, say, Industrial Land that is being used as an 

attractor. In all cases the model will take the previous year production. In this example, 

increments in industrial jobs will be allocated to zones as a function of the number of 

industrial jobs in the previous scenario and the amount of industrial and Business Park land 

also in the previous scenario. As will be seen, there are also zonal attractors to consider. 

Government jobs were incremented as a simple function of existing government jobs in the 

previous scenario. 

Next, the global amounts and possible zonal attractors are defined in Land Use -> Economic 

Data, as shown in Figure 47 for Industrial Employment in Scenario 96A. Make sure to select 

‘Increments’. As may be seen, the increment in the number of industrial jobs has been set to 

3603. In the base scenario 91A all zonal attractors were set to zero. Because in this menu 

actual increments are specified, the values shown for 96A are the ones that the model will use 

for the allocation of the increment. For instance, zone 1 has a zonal attractor of 0.8, making it 

slightly less attractive than zone 7 with a value of 1.4. The units of the attractors are irrelevant; 

it’s the proportions that matter. See the Math Manual for a detailed description of the 

allocation function. 

Go down the pull-down list to check growth for the Government employment sector. In this 

case the increment in government jobs is 336. 
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Figure 46: Defining allocation functions for exogenous production 

 

 

Figure 47: Defining a global increment and zonal attractors for exogenous production 
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Growth in the exogenous sectors affects all other induced sectors. In 96A there will be more 

population and more retail jobs and so on. These are determined by the intersector demand 

functions that were described for the base year (see Figure 20). In 1996 and subsequent 

scenarios, however, intersector demand values were allowed to change. To check this, open 

the Land Use -> Intersectors -> Inputs menu and navigate around the scenario tree to verify 

that the values actually change. These changes were introduced to account for some trends that 

are usually observed in urban areas: mostly that employment will grow faster than population, 

with annual rates of 1.6 and 1.4 respectively. These are very simplifying assumptions about 

the future growth in activities.  

If activities grow, floorspace and land will also grow, but this may not be possible in all zones. 

Some zones may have plenty of land available for future development, but others may have 

run out of available vacant land. In the centre of Swindon there are areas of historical value 

that cannot be touched. If demand for land grows but there is no real possibility for such 

growth, then the model assumes that land rents or prices will go up, thus affecting the location 

of activities. 

Possible increments are specified in the same Land Use -> Economic Data -> Increments, as 

shown in Figure 48. Pull down to sector 22 Framed floorspace and select the 96A scenario. 

This type of floorspace does not exist in zones 1 and 2, and because the values of Max. Prod. 

are set to zero, they cannot appear in 96A. Framed buildings do exist in zone 3, where there 

are 64,704 m2 in 91A. Here we are telling the model that this stock of buildings may grow, up 

to 6,500 m2 more. No minimum value was specified. The increment is also specified for the 

attractor, since the existing stock was used as an attractor in the base year. 

The lower part of the figure shows increments in Residential Land for Scenario 16T. In zone 3 

this type of land shows a negative increment in Max. Prod. of -2, that is, it was reduced by 2 

Hectares with respect to the previous scenario 11T. In this case the Min Prod and the Attractor 

were reduced by the same amount. This was done to accommodate other types of land, such as 

Mixed Land. Zone 3 has run out of available land by 2016, so that it cannot grow and prices go 

up. As a consequence, developers buy residential land (2 Ha in this case), turn it into Mixed 

land, pull down the houses and raise office buildings (Framed floorspace) in its place. The 

modeller must make sure that this is only allowed to happen where urban regulations admit it. 

Note that if 2 Ha are taken away from Residential Land in zone 3, the growth for both the 

maximum and the minimum must be equal to -2. 

When floorspace of a certain type in a specific zone is reduced, we will call it demolitions. 

When land of a certain type in a zone is reduced from, say, residential towards mixed, we call 

this redevelopment.  

The spreadsheet LandUseProjT.xls holds all data necessary for the calculation of future trend 

scenarios T, as well as the results. 
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Figure 48: Specifying increments in the production of floorspace 

 

 

 

5.2 Running the Trend Scenario 

Once all data has been put into place, running the Trend Scenario should be quite simple. Use 

the Project -> Run command, select the scenario, and proceed in the usual way. You may 

select one scenario at a time or several or all scenarios to run a long batch. 

In this example, all data has been set up for all scenarios and adjusted, so that it is safe to run 

all scenarios in a single batch. When a scenario is being developed, however, it is necessary to 

run the scenarios one by one. In the case of Scenario 96A, it is possible to run the land use 

model first. Keep in mind that the land use or location model reads transport costs and 
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disutilities of the previous scenario, that is, from 91A. This means that you may run location 

96A without running path search of 96A before. Once location 96A is ready, results must be 

checked and possibly adjusted. Check prices of land and floorspace and verify in your 

database if something can be done should prices go up too much in specific zones and land 

and floorspace types. It may be that the price of, say, residential land in a specific zone has 

gone up too much and there is more land that may be introduced into the market. Make such 

adjustments over and over, until you are satisfied that the system is in equilibrium and stable. 

It is very important that the location model should converge to a considerable extent. 

Once location and land use is stable, proceed with path building and assignment. It may be 

necessary to check the frequency of public transport routes, since demand may have gone 

beyond the capacity of some services and you may want to increase some frequencies. Once 

equilibrium has been reached, it is possible to proceed with the next scenario, in this case 01T. 

Proceed in this fashion until you reach the end of the branch in the scenario tree. 

5.3 Getting the results and setting up comparative tables 

Land use results 

Land use results are obtained in the usual way, as described in the previous chapter. The most 

interesting tables are generated automatically by the programs in the 

location_indicators_xxx.csv files. Results may also be obtained with program IMPTRA, 

Option 1. The idea is to produce one file per scenario and then compile them together on a 

workbook to obtain tables and graphs with the evolution of the system. In this demo the 

workbook LandUseProjT.xls contains all results and many comparative tables for the Trend 

Scenario. 

Figure 49 shows a section of a table compiled from the land use results, in this case showing 

sector 1 Agricultural and Industrial employment, from the base year 1991A to the last period 

2016T, including annual growth rates. Note that the workbook contains several sheets called 

91A, 96A, 01T, etc., where the results of the automatically generated files 

location_indicators_xxx.csv have been copied. For instance, in zone 7 there are 3,576 jobs in 

1991, growing up to 5,019 in 2016T. 

Many things can be done with these results, depending on the main interest of the study. 

Figure 50 shows a set of tables showing total consumption of floorspace and land by type and 

consuming sector in 1991. Similar tables were compiled for all other periods of the Trend 

Scenario. In this example, sector 1 Industry consumes 1,192,859 m2 of shed-type floorspace, 

and in turn sheds consume 474 Ha of Industrial Land. 

A number of tables, graphs and maps are presented next, all produced with the outputs of the 

Trend Scenario. Energy use was of particular interest in the study for which this model was 

built. Floorspace areas by type were multiplied by energy parameters to obtain fuel 

consumption and, consequently, fuel costs. The maps were produced with MapInfo reading 

model results readily from the Excel sheets. 
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Figure 49: Table compiled from the land use model results 

 

 

Figure 50: Total consumption of floorspace and land 
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Total consumption of floorspace with anual growth rates 

  1991 1996 % 2001 % 2006 % 2011 % 2016 %   

Sheds 1403655 1494196 1.3% 1602142 1.4% 1735872 1.6% 1907768 1.9% 2079356 1.7%   

Framed 1205266 1307582 1.6% 1432856 1.8% 1589262 2.1% 1791768 2.4% 1998731 2.2%   

Detached 1996799 2050287 0.5% 2158010 1.0% 2273559 1.0% 2432252 1.4% 2612690 1.4%   

SemiDet 2186583 2300434 1.0% 2413824 1.0% 2531566 1.0% 2651778 0.9% 2772455 0.9%   

Terraced 4173461 4402066 1.1% 4555783 0.7% 4766583 0.9% 4987840 0.9% 5266182 1.1%   

TOTAL 10965763 11554565 1.1% 12162614 1.0% 12896842 1.2% 13771406 1.3% 14729413 1.4%   

 

Total consumption of land with annual growth rates 

  1991 1996 % 2001 % 2006 % 2011 % 2016 %   

IndLand 583 614 1.0% 645 1.0% 688 1.3% 744 1.6% 800 1.5%   

Bparks 95 109 2.7% 129 3.6% 153 3.5% 182 3.5% 209 2.8%   

Mixed 190 206 1.6% 225 1.8% 250 2.1% 284 2.6% 324 2.7%   

ResidnLand 3557 3684 0.7% 3836 0.8% 4012 0.9% 4221 1.0% 4454 1.1%   

TOTAL 4425 4612 0.8% 4836 1.0% 5103 1.1% 5431 1.3% 5787 1.3%   

 

Energy consumption (Millions of KWh/year) 

2016 Sheds Framed Detached SemiDet Terraced Total 

Industry 386.1 229.9 0.0 0.0 217.7 833.8 

Government 0.0 38.0 0.0 0.0 0.0 38.0 

Retail 164.8 148.7 0.0 94.3 199.0 606.7 

Office 0.0 63.1 0.0 29.2 69.2 161.5 

HhdsHigh 0.0 0.0 627.6 391.3 453.3 1472.2 

HhdsMed 0.0 0.0 253.8 234.9 317.4 806.1 

HhdsLow 0.0 0.0 135.1 139.2 187.2 461.5 

TOTAL 550.9 479.7 1016.5 888.8 1443.9 4379.7 

 

Fuel costs by activity type (millions of £/yr) 

Activity 1996 2001 2006 2011 2016 Total 

Industry 20.5 21.0 21.6 22.1 22.7 539.5 

Government 1.4 1.4 1.4 1.4 1.4 35.4 

Retail 28.8 29.5 30.6 32.1 33.4 772.5 

Office 5.6 5.6 5.6 5.7 5.7 141.1 

HhdsHigh 30.6 30.8 31.2 31.7 32.4 783.4 

HhdsMed 26.2 25.4 24.6 23.8 23.0 614.8 

HhdsLow 15.6 15.5 15.4 15.4 15.4 386.6 

TOTAL 128.7 129.1 130.4 132.3 134.1 3273.2 
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Employment density 2016-T 
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Employment growth 1991-2016 Trend Scenario 

  

 

 

Transport results 

In a similar way, tables, graphs and maps may be produced from the results of the model. Use 

program IMPTRA to generate tables of indicators for each period of the Trend Scenario, or 

much easier, use the automatically generated file transport_indicators_xxx.csv. All such 

reports are easy to read with a spreadsheet and turned into comparative tables and graphs. In 

the case of maps, however, the situation is different in transport compared to land use. This is 

because standard GIS software, like MapInfo or ArcGIS are easy and flexible to use to 

produce thematic maps based on polygons, but they are not very good at networks. TransCAD 

provides many facilities to map transport results, but even then there are limitations and the 

interchange of information with any transport model, including TRANUS is, to say the least, 

cumbersome. At the heart of this ‘misunderstanding’ between transport models and GIS is the 

fact that networks in transport models are directional, that is, they go from an origin node to a 

destination node, or maybe both ways. In GIS networks are represented as polylines that have 
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no directionality. Directionality may only be an attribute of an otherwise non-directional 

geographical object. 

For this reason, TRANUS is provided with ample transport-related capabilities in terms of 

mapping. The interface reads the results of the simulations and represents them in 

geographical terms, combined with digital background maps with geographical coordinates, 

and a wide range of options. 

Figure 51 shows the kind of tables that may be built. The example shows total daily trips by 

transport categories and time period for the Trend Scenario, including annual growth rates. 

Note that growth rates in the number of trips are smaller than the growth in activities. This is 

due to elasticities in trip generation, because transport demand grows without an equivalent 

growth in network capacities, thus leading to increased congestion. Note that the workbook 

contains a sheet for each period, so that many tables may be compiled from them. What 

follows is a number of tables, graphs and maps that came out of the simulations. 

Note that the fuel consumption graph is strongly dominated by HOVs and SOVs, while public 

transport hardly shows. The table Distribution of vehicle-km by speed class is fundamental to 

the calculation of greenhouse emissions. Maps are produced directly by the TRANUS 

interface. The TUS Manual describes the numerous options to adjust, scale and color maps. 

Figure 51: Transport-related tables comparing several time-periods of the Trend 
Scenario 

 

 

Average travel time (minutes) 

Category 1991A 1996ª 2001T 2006T 2011T 2016T 

WorkHhdsHi 15.0 15.6 16.2 16.8 18.0 18.6 

WorkHhdsMed 16.2 16.8 17.4 18.0 18.6 19.8 

WorkHhdsLo 18.6 19.2 19.8 21.0 21.6 22.8 

Service 16.8 17.4 18.0 18.6 19.2 20.4 

Education 18.6 18.6 19.8 20.4 21.0 21.6 

External 28.8 29.4 29.4 30.0 30.6 30.6 

Average 17.23 17.71 18.43 19.14 19.74 20.82 
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Daily trips by operator for the Trend Scenario 

 

 

Fuel consumption by transport operator 
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Distribution of vehicle-km by speed class – Trend Scenario 

SpeedClass 1991 1996ª 2001T 2006T 2011T 2016T 

0-5 4695 6228 9728 11662 13952 20258 

5-10 35350 38209 44563 48582 54885 65903 

10-15 41271 48770 52133 86083 105235 126711 

15-20 52017 70201 98140 77735 96536 121404 

20-25 94482 88152 87449 139254 129836 129822 

25-30 107612 143836 170247 150176 148553 124874 

30-35 117343 91029 70212 85256 110435 259364 

35-40 133533 224136 257323 268337 290577 327496 

40-45 692807 663731 686491 741461 810428 748195 

45-50 185690 213812 248692 279369 285227 338846 

50-55 27700 33122 19224 54312 64543 143120 

55-60 53412 46441 101949 125031 100741 210109 

60-65 486920 558010 569331 576974 720295 618049 

65-70 395130 392297 433144 499784 467342 530728 

70-75 65129 135899 189892 204450 178420 223077 

75-80 417595 378830 315070 265604 284842 205520 

80-85 309066 334462 354642 382428 413418 449867 

85-90 1961945 2107091 2254846 2420408 2579593 2787329 

Total 5181697 5574256 5963076 6416906 6854858 7430672 

 

Assigned trips by mode 
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Assigned trips by mode 

  

 

Levels of service – Trend Scenario 2016 

 

 

walk bike 
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66  AAlltteerrnnaattiivvee  SScceennaarriiooss  

The Trend Scenario described in the previous chapter serves as a basis to compare alternative 

scenarios. This is because the Trend Scenario acts as a do-nothing case, or at least as little as 

possible. In this chapter a number of alternative scenarios are modelled and the results 

compared to the Trend. 

6.1 Description of the alternative scenarios 

Four scenarios were developed in detail and modeled, based on the same projections of total 

growth in households and employment envisaged in the Wiltshire Structure Plan of 1996, and 

used in the Trend Scenario. Each scenario starts in 1991 and was modeled through five -year 

intervals, to a horizon of 2016. The model was calibrated to data for 1991 and 1996. 

Population grows over the period by 32%, from 171,000 to 225,000, and jobs by 19%, from 

93,800 to 116,700. Average household size is projected to decrease, from 2.6 persons in 1991 

to 2.3 persons in 2016. The study area extends somewhat beyond the Borough of 

Thamesdown boundaries, to take in some commuter villages in N. Wiltshire and S. 

Oxfordshire. 

The four scenarios may be described as follows: 

A: Containment and increased density. This is a 'compact city' type of scenario in which all 

new land development is contained, at increased densities, within the existing urban 

area of Swindon; and development is prohibited on greenfield sites in existing villages 

or elsewhere in the rural hinterland. These land use policies are combined with a ban 

on car access to the centre of town, the creation of segregated busways along the main 

radial roads, and the provision of park-and-ride facilities where these main roads enter 

the town. A network of cycleways is also introduced. 

B: High density dispersal. This is in one sense the inverse of Scenario A. Development of 

new land is now forbidden in the existing urban area, and is directed instead into a 

series of existing satellite villages around Swindon. The two scenarios are similar 

however in that this new development is to be at high densities, and to incorporate 

industry and services as well as housing, so that the satellites can be more self-

sufficient. Use of public transport, cycling and walking is still encouraged. Restrictions 

are placed on the development of new land elsewhere in the rural hinterland. The 

accompanying transport policies are similar to scenario A, with a central area car ban, 

segregated radial bus-lanes and the park-and-ride scheme. They differ in that busways 

and enhanced bus services are also provided on orbital routes linking the satellites to 

each other; and some new commuter stations are built on existing railway lines. 

C: Limited peripheral expansion. This scenario follows the policies being pursued by the 

Swindon Borough Council at the time the study was carried out. The greater part of the 

growth is accommodated within a limited 'town expansion' area on the north-east edge 

of the town, where residential development is combined with some industry and 
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services. The scenario has affinities with A, in that the supply of new land is restricted 

to Swindon itself - albeit extending the edge of the town. A large former industrial site 

in the town centre is also redeveloped with mixed uses. The expansion area is served 

by a new orbital road with segregated bus-lanes. A bus-based park-and-ride scheme, 

priority bus routes, and one new commuter railway station are introduced. The 

scenario, as modeled, also incorporated the central area car ban as in the other 

scenarios. The Borough did not envisage this, only restriction of central area car 

parking. 

T: Trend. This is the scenario described in the previous chapter. It was introduced simply for 

purposes of comparison. The Trend Scenario embodies no explicit land use or 

transport policies, but simply lets new development go where it wishes. Public 

transport provision follows demand, and no improvements are made in transport 

infrastructure. 

Specifying land use constraints 

Scenarios A, B and C involve strict constraints to future land use and expansion, while T 

assumes that developers are going to introduce new floorspace and land more or less freely. 

These policies are represented in the model as values in minimum and maximum constraints 

in menu Land Use -> Economic Data -> Increments. 

Specifying park-and-ride facilities 

As mentioned, the Trend Scenario does not include specific transport projects or policies. 

Alternative scenarios do have many and of various kinds. Here is a description of how they are 

introduced to the model. All alternative scenarios have park-and-ride facilities in the periphery 

where car users may park and then transfer to bus or rail. 

To visualize the P&R facilities, chose any of the alternative scenarios in the Link Type 

network view. Assign colors to link type 20 Railway, 22 P&R and 27 Bus Link. You should 

get a view like the one shown in Figure 52. P&R are represented as little triangles, linked or 

close to rail and bus links. In this way cars drive into one side of the triangle, transfer to park 

and ride on another side and come out with a transfer to bus or rail. 

The P&R fares are integrated, as was described before. Check the menu Transport -> 

Transfers to verify that cars are allowed to transfer to the P&R operator, and that from there 

travelers may transfer to bus or rail. Next look in the menu Transport -> Link Types and select 

link type 22 P&R. In the Operator Data tab the following operators have speeds of 5 Km/hr: 

HOV, SOV, Bike and P&R. This means that travelers may drive into the P&R facility in any 

of the two car modes or bike and park there. 
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Figure 52: P&R, bus lanes and rail in alternative scenarios 

 

 

 

Specifying bus-only lanes 

Three bus-only corridors were defined, as shown in Figure 52 above. These were coded as 

zigzagging links parallel to the roads themselves. A detail is shown in Figure 53. In the 

network view double-click on any of the bus-only links. You will see that the link type is 27 

Bus Link. Click on the Link Type button to display the data related to this link type. In 

Operator Data you will see that speeds are assigned to all types of buses, but not for HOV and 

SOV cars. In other words, this type of link may only be used by buses. Bus lanes were given a 

capacity of 1000. Now click on any of the roads to which the bus lanes are related. It will be 

seen that such roads have a reduced capacity compared to what they had in the base scenario. 

This means that the new bus lane was built by extracting capacity from the road. 
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Figure 53: Coding bus-only lanes 

 

 

Specifying  a new rail line 

The idea of this project is to make use of an existing intercity railway and introduce a 

suburban commuter service. This is simply coded as a straight line connecting the periphery 

with the city center. This is also seen in Figure 52. In this case not only the link was defined 

but also a route that runs along the link called 601 GlostRail. Check the corresponding route 

and operator data in the routes and operators menus. 

Specifying car-ban in the town center 

Complementary to P&R, rail and bus-only lanes, cars were banned from the town center. The 

best way to see how this was coded is as follows. In the Link Type network view assign a 

color to link types 3 and 4, and another color to link types 9 and 10. Then select the Scenarios 

tab and navigate back and forth from scenario 96A to 01A. In this way you will see that streets 

in the town center change colors. Then check the characteristics of these link types and verify 

that cars may use types 3 and 4, but not 9 or 10. 

6.2 Running the scenarios 

Running the scenarios is a relatively straightforward matter from an operative point of view. 

However, there are a number of adjustments that must be made as the simulation process 

proceeds into the future. The main adjustments are: 

 Floorspace and land must be adjusted, increasing supply where necessary and possible, 

to reflect land availability and the land use policy being simulated. 

bus lanes 

original road 
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 Public transport frequencies must be adjusted to accommodate growth in demand, or as 

new transport systems are introduced in some scenarios, frequencies must be adjusted 

to adapt each new component. 

Unfortunately there is no ‘automatic’ way of doing these adjustments, although the software 

does provide a number of facilities. These adjustments have already been made in the database 

provided. 

Running the programs 

Actually running the programs is done the same way as described in the previous chapter. 

Simply use the Project -> Run menu and use the default settings. With the run menu you may 

run all scenarios and time periods in a single action. In fact this is possible with the provided 

database, because everything has already been adjusted. When running a scenario for the first 

time, however, it is necessary to proceed one period at a time. Furthermore, it is necessary to 

run land use first, make the land use and floorspace adjustments over and over until satisfied, 

and then proceed with the transport runs and adjustments. 

Adjusting land and floorspace 

Adjusting land and floorspace is made as described in the previous chapter for the Trend 

scenario. The procedure is as follows: 

 Run a time-period of a scenario without increments in the supply of land or floorspace. 

 Analyse the results in location_indicators_xxx.csv, verifying possible increments in 

prices. If the price of a particular type of land or floorspace increases with respect to 

the previous period, increase supply if possible. 

 If an increment in the supply is not possible, consider transforming one type of 

floorspace and land for another, such as changing low-density residential land for high-

density residential land or industrial for business parks. 

 Re-run the model and check the results. Repeat until prices grow at reasonable rates. 

It is recommended that you set up a spreadsheet to keep control over the process. 

Adjusting public transport frequencies 

For each time-period public transport frequencies must be adjusted. The procedure is quite 

simple. Run transport assignment without any increments in frequencies with respect to the 

previous period. Inspect file route_profile_xxx.csv to get the list of routes and check the 

critical volume and volume/capacity indicators for each route. If a route has gone beyond 

capacity, the maximum frequency may be increased. Note that a maximum fleet parameter 

may be activated to avoid unreasonable growth, usually as a result of increased congestion, 

but this feature has not been used in this modelling exercise. 

6.3 Producing comparative tables, graphs and maps 

At this point we are interested in producing a set of tables that compare the results of the same 

variable for different scenarios. The procedure to produce tables of results and indicators for a 
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single scenario, the Trend Scenario, was described in the previous chapter. The same must be 

applied to each one of the four scenarios that were developed. In the case of land use results, 

files location_indicators_xxx.csv are used to produce tables for each scenario/period. The 

resulting tables are pasted into spreadsheets where they can be compiled into comparative 

tables. A GIS is then used to produce maps with the results. Similarly, files 

transport_indicators_xxx.csv are used produce a set of transport-related indicators tables, and 

the TRANUS interface is used to produce transport-related maps. What follows is a set of 

tables, graphs and maps that were produced to analyse the results. Tables and graphs are at an 

aggregate level for obvious reasons. 

The totals of employment and population are the same for all scenarios, but the location varies 

depending on the land use policy. From the results of the model and using a GIS, a number of 

maps were produced, as may be seen in the following pages. Even if the totals of population 

and employment are the same for all scenarios, total consumption of floorspace and land show 

variations as a result of the land use policies. 

Table 3 compiles the total consumption of floorspace by scenario and period in m2. Because 

consuming activities grow, floorspace also grows, but as the amount of available land varies 

for each scenario, the amounts consumed also vary. The table shows that the Containment 

Scenario is the one that grows the least, as expected, and the Trend Scenario grows the most. 

The differences are, however, not very big. Between A and T is 811 thousand, in the order of 

5% of the total stock. Figure 54 shows these results in graph form (Note that the graph is 

cheating because the y axle begins at 10,000. This was done to emphasize the differences.). 

Table 3: Consumption of Floorspace by Scenario (Thousands of m2) 

Scenario 1996 2001 2006 2011 2016 16-96 

A Containment 11555 12114 12702 13247 13918 2364 

B Hinterland 11555 12180 12933 13744 14569 3014 

D Peripheral 11555 12149 12798 13508 14220 2666 

T Trend 11555 12163 12897 13771 14729 3175 
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Figure 54: Consumption of Floorspace by Scenario 

 

 

Figure 55 shows a set of four maps, one for each scenario, depicting the difference in total 

employment for each zone, for the period 1991-2016. As expected, the Containment Scenario 

concentrates employment growth in the central area of Swindon, as opposed to Trend and 

Hinterland where growth spreads out. The rest of the maps show consistent results. 
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Figure 55: Employment Growth – 1991-2016 
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Figure 56: Population Growth 1991- 2016 
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Figure 57: Income distribution - 2016 
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Figure 58: Floorspace Growth 1991 - 2016 
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Figure 59: Land Development Growth 1991 - 2016 
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Figure 60: Land Value Index - 2016 
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Figure 61: Demolitions 1991 - 2016 
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Table 4 and Figure 62 show the consumption of land by scenario and period in Ha. Again the 

Containment Scenario shows the least growth in consumption and the Trend shows the most, 

with a difference of 615 Ha, representing more that 10% of the total stock. This is because 

activities find it easier to reduce plot sizes compared to reducing actual floorspace 

consumption. 
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Table 4: Consumption of Land by Scenario (Has) 

Scenario 1996 2001 2006 2011 2016 16-96 

A Containment 4612 4793 4944 5058 5173 561 

B Hinterland 4612 4832 5064 5306 5549 937 

D Peripheral 4612 4801 4954 5102 5243 631 

T Trend 4612 4836 5103 5431 5787 1176 

 

Figure 62: Consumption of Land by Scenario 

 

 

The research team was able to estimate fuel consumption per square meter of floorspace by 

type based on an extensive study of the built stock in Britain. These values were applied to the 

results above to get millions of kWh/year. These were in turn multiplied by the price of energy 

to get fuel costs in millions of £ per year. In this case the difference between the Trend and 

Containment scenarios is in the order of 86 million £ per year representing 12.8% of the total. 

As may be seen, fuel cost savings are greater than the reduction in floorspace consumption. 

This is because the amounts of m2 are less in the Containment Scenario compared to the 

Trend. Building types also vary, with a greater proportion of framed buildings, terraces and 

flats that consume less energy per m2 compared to sheds and detached houses. 
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Figure 63: Consumption of Floorspace Energy by Scenario (Millions of kWh/year) 

 

 

Figure 64: Fuel costs of buildings (millions of £/yr) 

 

 

Some interesting transport-related tables and graphs follow. 
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Table 5: % passenger-Km in public transport 

Scenario 1996 2001 2006 2011 2016 

A Containment 6.4% 13.1% 13.4% 13.7% 13.9% 

B Hinterland 6.4% 13.5% 14.3% 15.2% 15.7% 

D Peripheral 6.4% 12.9% 13.0% 13.3% 13.5% 

T Trend 6.4% 7.0% 7.2% 8.3% 8.4% 

Table 6: % passenger-Km in non-motorized modes 

Scenario 1996 2001 2006 2011 2016 

A Containment 4.1% 8.6% 8.5% 8.5% 8.6% 

B Hinterland 4.1% 8.5% 8.3% 8.5% 8.7% 

D Peripheral 4.1% 8.5% 8.1% 8.1% 8.1% 

T Trend 4.1% 4.2% 4.4% 4.5% 4.7% 

Table 7: Park&Ride trips 

Scenario 1996 2001 2006 2011 2016 

A Containment 0 39825 46635 49917 53065 

B Hinterland 0 37637 43929 50100 55654 

D Peripheral 0 37911 46021 49044 52389 

T Trend 0 0 0 0 0 

Figure 65: Total operating cost savings (thousands per year) 

 

 

0

10

20

30

40

50

60

70

80

90

100

1996 2001 2006 2011 2016

0
0
0
 £

 p
e
r 

y
e
a
r

year

A Contain

B Hinterl

D Periph



Application guide to the model of Swindon  TRANUS 

 

 91 

Figure 66: Total fuel consumption 

 

Figure 67: Distribution of vehicle-km by speed class -2016 

 

 

600,000

700,000

800,000

900,000

1,000,000

1,100,000

1,200,000

1,300,000

1996 2001 2006 2011 2016

F
u

e
l 
c
o

n
s
u

m
p

ti
o

n
 (

lt
rs

 p
e
r 

d
a
y
)

year

A Contain

B Hinterl

D Periph

T Trend

0

100,000

200,000

300,000

400,000

500,000

600,000

700,000

800,000

0
-5

5
-1

0

1
0
-1

5

1
5
-2

0

2
0
-2

5

2
5
-3

0

3
0
-3

5

3
5
-4

0

4
0
-4

5

4
5
-5

0

5
0
-5

5

5
5
-6

0

6
0
-6

5

6
5
-7

0

7
0
-7

5

7
5
-8

0

8
0
-8

5

V
e
h

ic
le

-K
m

Speed-class (Km/h)

A Contain

B Hinterl

D Periph

T Trend



Application guide to the model of Swindon  TRANUS 

 

 92 

Figure 68: Assigned trips - 2016 
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77  FFiinnaall  rreemmaarrkkss  aabboouutt  tthhee  rreessuullttss  

Although the main purpose of this guide is to help run the model of Swindon, reproduce the 

results and describe how to produce reports and analyse them, it is worthwhile to sum up some 

important conclusions and remarks about these results. Here we shall discuss each scenario in 

turn and then put together some general remarks. 

7.1 Scenario A: Containment and increased density 

Land use results 

Scenario A specifies that new land for development is made available only within the existing 

urban area of Swindon. The implementation of this policy is shown clearly in the map of Land 

Development Growth 1991-2016 in Figure 59. Employment growth over the period is largely 

confined to this same area, although there is also growth in some peripheral rural zones to the 

south-west. (This is made possible by increases in density on already-developed land. There is 

no new land take in these zones.). 

Commercial and industrial activities are in competition with residential uses for land and 

floorspace in Swindon, a competition in which the former are able to outbid the latter. As a 

result, although population does grow within Swindon itself, it actually grows faster in the 

outer rural zones. These peripheral housing developments are shown by the map of Floorspace 

Growth 1991-2016 in Figure 58. The increases in floorspace in the south and west are partly 

due to employment growth as we have seen, but the increase to the north of the town, and 

some to the south, is largely residential.  The biggest land use changes between 1991 and 2016 

in this scenario are within Swindon itself, but there are high rates of change in land use in the 

rural hinterland, especially in the zone containing Highworth to the north-east. Because of the 

limits on land supply, the Containment Scenario results in high floorspace densities in the 

urban area, and high land values associated with those high densities. The map of Demolitions 

in Figure 61 shows that these are confined to Swindon itself. The growth in floorspace in the 

hinterland zones is thus entirely achieved by increased densities within parcels of land which 

were already developed in 1991. 

The growth of housing outside Swindon is one of the most significant findings for this 

scenario. Proponents of a 'compact city' approach argue  that redirecting development towards 

existing urban centres will result in a lively mixture of commercial with residential uses, and 

shorter journeys from home to work and from home to services. The results for this 

Containment Scenario raise a warning that, unless special measures are taken to keep housing 

within city centers, there is a danger that restrictions on land supply in peripheral or hinterland 

areas may, paradoxically, serve to drive housing out of town. Commercial and industrial 

growth must go somewhere, and if it can only go on central urban sites, this will raise land 

prices and rents, and may force housing to go elsewhere. 
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Transport results 

So far as overall travel patterns are concerned, the Containment Scenario has the effect of 

doubling the trips made by public transport, over the period from 1991 to 2016. Even so, this 

proportion is still only 14%, i.e. about one trip in seven. The greater part of the shift to public 

transport occurs immediately on the introduction of the car ban and the park-and-ride scheme, 

between 1996 and 2001. The map of Assigned trips in 2016 shows the city centre free of cars, 

as the scenario specifies. The only motorized trips in the centre are now by bus. Non-

motorized journeys, i.e. cycling and walking, are more than doubled from 4% to over 8% of 

all trips, again as a result of the central area car ban.   

There are a series of consequences for overall travel statistics. The average trip length is more 

or less unchanged. This is because some shorter trips in centre due to higher densities, are 

compensated by longer ones outside, going round the city centre by car, or coming in from 

peripheral housing developments. The average trip cost falls slightly, because of the shifts in 

mode to walking, cycling and public transport, including use of the park-and-ride scheme 

(even though parking charges are assumed to be included in the bus fares). Average travel 

time increases over the entire period, because of the shifts to slower modes. When modal shift 

is examined in more detail, it becomes clear that the major changes are from cars carrying 

several occupants, to public transport and non-motorized modes. 

The implication of these results is that it is the middle-income groups who are mostly making 

the shifts in mode away from the car. The lower income groups travel more by public 

transport, bicycle or on foot in the first place. Meanwhile the higher income groups are not 

attracted by the park-and-ride option, and are not greatly deterred by the central area car ban, 

and carry on driving regardless. This is shown by an increase in fuel use by cars with single 

occupants in the Containment Scenario, because these are being used to make longer, more 

circuitous journeys around the town centre. There is also the fact of higher-income housing 

being pushed out to rural zones outside Swindon, as already mentioned. 

7.2 Scenario B: Hinterland, high density dispersal 

Land use results 

In this scenario, new employment and services are exported to a number of existing villages in 

the hinterland of Swindon: Cricklade, Broad Blunsden, Highworth and Shrivenham to the 

north; Purton, the Lydiards and Wootton Bassett to the west; Wroughton and Chiseldon to the 

south. New housing follows these jobs and services. Meanwhile new development is severely 

restricted in Swindon itself. The effects of these constraints are clearly visible in the maps of 

Land Development Growth and Floorspace Growth. New land gets developed by 2016 in most 

of the rural zones, especially to the south-west and north-west. 

The map of Employment Growth confirms this picture. It shows growth in most of the 

hinterland zones, especially strong to the south-west around Wroughton and Wootton Bassett, 

which are both well-placed for access from the M4 motorway. There is some increase in 

employment in Swindon itself, on land already developed in 1991, but this is not as marked as 

in the Containment Scenario, as expected. Growth in population follows employment, as 
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housing moves to the sub-centres. The resulting pattern of population growth in the hinterland 

is not greatly different from that which occurs in the Containment Scenario for the reasons 

explained above. Floorspace densities and land values are somewhat lower generally than in 

the Containment Scenario, because the supply of land is greater. There are fewer 

redevelopments and conversions, for the same reason. 

Transport results 

Some of the transport policies embodied in this scenario are the same as for Scenario A: the 

central area car ban, the radial park-and-ride scheme. The biggest difference lies in the 

creation of orbital routes linking the satellites, with bus services running along segregated bus-

lanes. The result is the largest shift to public transport of all scenarios, up to nearly 16% of all 

trips (one in six). Trips along the orbital bus routes can be seen (as green bands) in the map of 

Assigned Trips 2016. Use of the park-and-ride scheme is slightly increased compared to the 

Containment Scenario, as a result of the residential population being more widely spread into 

the hinterland. Meanwhile the shift of trips to walking and cycling is similar to Scenario A (up 

from 4% to nearly 9%) since this is largely brought about by the central area car ban in both 

cases. 

As for average trip cost in 2016, it is also similar to the Containment Scenario. Average trip 

length and travel time are very slightly greater, because of the dispersion of employment and 

population over a wider area. But this effect is not very marked. 

A further difference in transport policies in this scenario was the introduction of four new 

suburban stations on the existing railway lines. These however have negligible effects on 

traffic patterns, and the numbers of users are very small. This is perhaps because the stations 

are few in number and not in places where demand would be highest.  

7.3 Scenario C: Peripheral - limited peripheral expansion 

Land use results 

New land for residential development is made available, in this scenario, only in an area on 

the north-west edge of Swindon. Some industrial and commercial growth is also allowed in 

this area, as well as on one large former industrial site in the town centre. Otherwise 

development in the hinterland is severely controlled.  The map of Land Development Growth 

illustrates these constraints. There are some broad similarities with the Containment Scenario 

in the resulting land use patterns - although in different zones - as a result of the supply of land 

being greatly restricted in both cases. 

Employment grows most sharply in the designated north-western area, as would be expected, 

but it also grows in Swindon itself, and in other parts of the hinterland especially those same 

zones to the south-west which grow strongly in the Hinterland scenario. Floorspace growth 

follows a similar pattern, with additional residential development occurring (through increased 

densities on land already developed) in the rural zones to the north of the town, beyond the 

designated growth area. This is again comparable with the Containment Scenario. In both 

scenarios the limits on the supply of land mean that some housing is driven out into the 
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countryside. The growth of population in two northern rural zones in particular - those 

containing Highworth and Cricklade - results in especially high rates of redevelopment and 

conversion. 

Transport results 

A new orbital road, with special bus-lanes, is built in this scenario to serve the north-western 

expansion area. A park-and-ride scheme is also introduced, plus some other segregated and 

priority bus routes. There is a ban on cars in the town centre as in both previous scenarios. The 

consequence is again a shift to public transport, from 6% of trips in 1996 to 13.5% in 2016 - 

very nearly as large a change as in the Containment Scenario. The park-and-ride scheme 

attracts almost the same number of riders in the two scenarios.  

The scenario introduces one new suburban station with associated car parking, but the effects 

of this on modal shift are even smaller than in the Hinterland Scenario with its four stations. 

7.4 Scenario T: Trend 

Land use and transport results 

There are no constraints on amounts of land available for development, and no new traffic 

management policies or public transport initiatives, in this scenario. It is not intended to be 

realistic in itself, but is introduced simply to serve as a 'do-nothing' benchmark against which 

the previous three scenarios can be compared for their effects.  As might be expected, there is 

growth in newly developed land, and new floorspace, both in Swindon itself and in the 

surrounding rural zones (although the latter not as marked as in the Hinterland Scenario).  

Because land is freely available in many zones, there are few changes in land use, and little 

redevelopment. Land values and densities remain lower than in other scenarios. Population 

growth in the rural areas is greater than in the Hinterland Scenario, and is broadly comparable 

with the Constrained Scenario. This is because middle and higher income groups are seeking 

more land and larger houses in the outlying villages – a process whose effects are visible in 

the map of Income Distribution. 

The results for traffic patterns are that use of public transport increases hardly at all (from 6% 

of trips to 7%). There is practically no shift to cycling or walking. All this has the effect that 

the average trip cost is significantly higher in the Trend Scenario than all others. Average 

travel time is also the highest of all, by a small margin. This is because, although a higher 

proportion of trips are by car, new development is very spread out, and more importantly the 

cars cause congestion, hence travel times deteriorate. Because the model simulates all-day 

traffic flows, the predicted effects of congestion are not especially serious in any of the 

scenarios, even the Trend. Simulation of peak-hour flows would doubtless show a different 

picture. 
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7.5 Comparative performance of all four scenarios 

Land use, floorspace and energy in buildings 

We are now in a position to make some quantitative comparisons of the overall performance 

of all four scenarios. Scenarios Constrained and Peripheral take the smallest areas of extra 

land - 560 and 630 hectares respectively - as would be expected from their inherent constraints 

on new development.  The Hinterland Scenario takes 940 hectares, and the Trend Scenario, 

which places no restrictions at all on development, takes 1050 hectares. A similar ranking of 

scenarios gives total consumption of floorspace over the same period. Again the Constrained 

and Peripheral consume the least, the Hinterland and the Trend the most. (The Hinterland 

Scenario actually consumes more new floorspace than the Trend). The differences are not 

however so marked as for land, because of greater elasticities in land consumption. 

These differences in consumption of land and floorspace have some impact, in turn, on the use 

of energy in buildings. A general improvement in the energy efficiency of buildings was 

assumed at the same rate for all scenarios. This serves to offset part of the growth in energy 

use which occurs otherwise simply through increases in total floor area. Total energy use in 

the Hinterland and Trend Scenarios still goes up over the period to 2016. In the Peripheral 

Scenario it rises and then falls again.  In the Constrained Scenario it falls throughout. By the 

end year 2016, total energy use per annum is 4.5% lower in the Constrained Scenario than in 

the Trend, and in Peripheral it is 3% lower. These results translate into similar percentage 

savings in energy costs per annum. 

Notice that these comparative results have nothing to do with any technical improvements in 

the fabric or servicing systems of buildings, which are assumed to be the same in all cases. 

They result wholly from changes in built forms, of two kinds. First, in those scenarios where 

land is in short supply and densities rise, the same activities occupy less floor area (smaller 

houses, less office floorspace per employee etc). Second, the higher densities have the 

additional effect that the same activities tend to locate in more compact forms with a lower 

ratio of surface to volume: residential in terrace or semi-detached rather than detached, other 

activities in multi-storey framed buildings in preference to single-storey sheds. 

The most marked reductions in fuel consumption, in the Constrained and Peripheral scenarios, 

are shown by middle-income households, a proportion of which have moved by 2016 into 

smaller houses of more energy-efficient types. The high income households meanwhile are 

able to continue to afford larger detached houses. The low income households are already in 

small energy-efficient dwellings in 1996. 

Transport mode and energy in transport 

There is little difference between the scenarios in the predicted total number of trips in 2016 - 

of the order of 4.5% between the highest and lowest. The main differences are rather in modes 

of transport. To recapitulate: all three scenarios result in greater use of public transport 

compared to the Trend, by between 6.5 and 8%, as a result of the combination of central area 

car ban and park-and-ride. These scenarios have between 3% and 4% more trips by cycling 

and walking than in the Trend, because of the car ban. 
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The Containment and Peripheral scenarios produce savings of around 13% over the Trend by 

the year 2016. In the Hinterland Scenario the savings are lower, around 11%, because of trips 

being on average slightly longer. The pattern of vehicle fuel consumption in 2016 is still 

absolutely dominated by cars, which account typically for 98% of the total. Fuel savings in the 

Constrained and Peripheral scenarios occur, as mentioned earlier, as a result of some users of 

cars with several occupants shifting to other modes. In the Constrained Scenario, fuel use by 

single occupant cars actually increases, because of households in the relevant groups moving 

outside of Swindon, and because circuitous routes are being taken around the area of the car 

ban. 

7.6 Overall conclusions 

To an extent these results must be peculiar to Swindon. It would be dangerous, without more 

work, to claim any general validity, even for other towns of similar size, since these might 

differ greatly from Swindon in densities, the extent of undeveloped central area land, and 

other significant characteristics. The results do seem to indicate nevertheless that for Swindon, 

and possibly for other comparable towns: 

1) The effects of land use changes by themselves, for towns of this order of size, in 

reducing car travel or encouraging modal shift to public transport, cycling or 

walking, are small. 

2) The combination of a central area car ban with a comprehensive park-and-ride 

network, using segregated bus lanes, can shift up to 8% of trips from cars to other 

modes, and to save up to 13% in total annual fuel use in transport. 

3) These modal shifts are of almost the same magnitude for a land use policy which 

directs new development to satellite villages around the town, as for land use 

policies which contain new development either within, or on the edge of the town. 

4) A policy of containing new development within or adjacent to the existing urban 

area - i.e. a 'compact city' approach - can, by restricting the supply of available 

land, have the effect of raising densities and land values in these zones. Industrial 

and commercial uses then drive out housing, which cannot compete, to rural areas 

outside the town. Thus two of the explicit aims of the 'compact city', to encourage 

mixed uses in town centers, and to bring jobs and services closer to houses, are 

subverted. 

5) On the other hand, this same restriction on the supply of land, and the resulting 

increases in density, mean that activities occupy less floorspace, in more compact 

building types, and the total use of energy in buildings is reduced, by these built 

form effects alone.  (Their impact is not however large, of the order of 3% or 4% of 

total fuel consumption.) 

6) It is changes in behavior by middle-income groups, from less efficient to more 

efficient house types, and from car travel to other modes, which bring about the 

greater part of these savings in fuel use in both buildings and transport. The scope 

for savings by low-income groups is small to start off. High-income groups can 

afford to meet the costs of increasing their use of cars, and of continuing to occupy 

larger detached houses. 
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From a methodological point of view, it is quite clear that only integrated land use and 

transport models can produce this sort of results. In this case, since we are demonstrating a 

specific model, TRANUS, it is hoped that the reader, after going through the exercise in detail, 

is convinced of the advantages of this methodology over common practice, such as ‘expert 

analysis’ and maybe conventional transport-only models. Real cities are far too complex, so 

that powerful analytical tools like this sort of model is required. 


